A couple of minor things about WebTop


I have deployed Nethserver with Webtop at our office with 15 users. I have noticed a couple of minor things so far which may be oversights or bugs (probably easy to fix) and would also like to comment on some things that would make the Webtop client better (just my opinion of-course!).

Maybe I should start new topics but being quite new to the Nethserver Community I wasn’t too sure whether to do that.

Firstly, the issues I have noticed so far:-

  • English spelling mistake. Mostly noticable on the main email page. Messagges should be Messages. I’ll keep my eye out for more. Very minor issue but worth mentioning for future versions.
  • The calendar seems to have an issue which I think is related to the timezone you set. For example, I have TZ=Australia/Brisbane (which is +10). When I set a calendar event before 10am, the event goes in to the day before but still has the correct time & date. If I change my TZ, the same thing happens. Eg. Australia/Perth (+8), any event prior to 8am is shown on the calendar view in the day before. In both cases my mobile (Z-push) shows the event correctly.

Now, some things I think may improve Webtop. It’s entirely possible that some of these things may already be implemented and I haven’t worked out where to enable them:-
Option for no “are you sure” prompt when deleting trash (and maybe junkmail too).
Option to automatically delete trash when logging off.
Retain folder view at next logon (I have lots of subfolders and have to keep expanding them).
Option to switch off the preview pane. Not a biggy but some people might like the option.
Ability to remove any attachment from email by right-click “Remove”. This is something I have always used a lot where I want to keep the email text but remove the attachment after I have saved it elsewhere (maybe a large manual someone sent me for example) to keep my quota down.

Finally, I just thought I’d share how I put my company logo on the Webtop login page. I looked everywhere for instructions without luck and sort of stumbled on a solution by trial and error. Maybe this can help someone else.

The sonicle logo on the login page is called login.png and is 625 x 265px with background colour #f8f8f8.
So I made a png file with my logo the same size and fill the backround the same colour and named it login.png.
Then I used the “tools | public images upload” in webtop admin to upload my file.
Restart and my logo was in the login page.

Looks pretty good. https://gw.multicomqld.com.au/webtop if anyone wants to see it. You may need to refresh if the connection times out the first time. This happens a lot but I haven’t worked out why yet. Probably my firewall or something in my NS ssl setup.


Wow good points reported, thanks for your time and your effort on WebTop. @lucag and @gabriele_bulfon are going to be really happy about that, and they may help you to understand whether these things are bugs or not.

Great post Greg!
We will surely consider your suggestions for a forthcoming update.
Happy to see you found yourself how to customize the logo!

Just a note : you already have the option to remove the preview pane, just by minimizing it clicking on the handle in the middle of the view splitter.
Once this is minimized (be it horizontal or vertical), it will not change messages seen states while navigating the grid :smile:


Thanks Gabriele

Can you shed any light on the calendar issue? We use shared calendars to set appointments for our staff and it’s quite confusing when every appointment before 10am is displayed in the previous day in webtop.

I have another couple of problems while I’m at it.

  • When connecting using https://servername/webtop, my connection times out in the first instance and the returned url is without https (http). If I click back to use https I can log in. When I allow tcp80 through my external firewall (which I really don’t want to) it works every time. I think it’s something to do with the apache rewrite engine but only for webtop (https://servername/sogo is ok without tcp80 open in firewall).
  • Having lots of problems with z-push. Works ok for a while but then I get mobile loop detection errors and nothing new will sync. I have studied the z-push docs and tried lots of things. Is there any known issues with webtop/z-push?


The calendar guys here are looking at the time zone issue.
Hope I can get back to you soon.

About the connection problem, I’ve never heard of it within NethServer on any of their installation.
Maybe they can shed some more light on it.

About z-push / webtop, we have around a thousand users running every day on it, without issues.
I will check with the z-push guys about the loop detection problem, but it may still be the same access problem you get on webtop https.


I’m pretty sure the connection problem is a separate issue. I don’t have the problem when I’m on our LAN, only outside (unless I port forward tcp 80). I think when you use https there is some part of the initial connection trying to use tcp 80. (As I said, https to sogo is fine). I’ll investigate further when I get a chance.

The same applies with z-push. Devices directly connected to our LAN (no firewall) still have the loop detection problems. Once again, I’ll spend some more time on it soon. The annoying part is that once there is a sync issue, nothing new works in the problem folder (eg. Inbox) on the device. The z-push docs say that it will skip that message and do 1 message at a time when in loop dtection mode.

This could be a clue: My android has been fine for weeks. I added a task 2 days ago and I also re-arranged some mail into different subfolders yesterday and since then it’s not working. z-push-config.php showed a problem with the task but I can’t get it working again yet (even though I deleted the task).

1 Like

I’ve done some more testing today.

Regarding z-push:-
I’m finding that we have a lot of “broken” emails which are causing the mobile device sync to fail. This may be partly due to the way I brought each user’s email from our old server to nethserver. I find the z-push logging very difficult to follow, it’s not easy to work out which particular message is causing the problem. I have mine working again now - I noticed which was my last successful sync and worked out the next email in the queue was the problem, Once I got rid of it, the rest synced ok.

Regarding ssl timeout:-
I confirmed (using wireshark) that going directly to https://servername/webtop does try to use tcp port 80 after the initial certificate negotiation (and then redirects to https which was what you started with in the first place). The same happens when logging in. This needs to be fixed as it is not desirable to set nat port forwards to nethserver tcp port 80 when you are trying to use (force) ssl. I tried a few changes in /etc/httpd/nethserver.d/00default:443.vhost without success. Maybe someone with more nethserver https knowledge can help. I suspect a change in 00default:443.vhost may help.

For anyone who’s interested, I decided to try and find a workaround for the annoying ssl timeout when connecting to webtop from outside. This occurs because the webtop httpd config tries to communicate via tcp port 80 even though the initial connection is using tcp 443.

I didn’t want to set a permanent nat tcp 80 port forward to nethserver so I simply set up a simple port “knock” rule in my router. Any incoming connection from the internet to tcp 80 adds a temp source address allowed rule for 5 seconds which allows the tcp 443 chit-chat to begin and then port 80 closes. No more timeout!

Still haven’t heard anything regarding the timezone issue with the webtop calendar. Any news anyone?

We faced the same issue a few days ago, you’re totally right it’s a bit awkward. I hope @gabriele_bulfon is able to help us :wink:

Hi, the TZ issue has been resolved few days after your post.
We have released new wars to Nethesis already, I hope they will release the update through their update channel.

About the 443/80 issue, we will look at it again: your trick has opened some ideas of resolution.


About the https problem, we have found that on NethServer you may have this option on apache configuration:

ProxyPreserveHost On

Removing this option makes everything work fine.

Alessio may have the correct answer on how to remove this option from NethServer.
Our test installtion had it inside /etc/httpd/nethserver.d/00default:443.vhost

The ProxyPreserveHost is default to off, but is enabled only from SOGo configuration fragment.
You have two possible solutions:

  1. remove nethserver-sogo

  2. create a template custom (I don’t if disabling the option affects in any way SOGo installation):

    mkdir -p /etc/e-smith/templates-custom/httpd/vhost-default/
    cp /etc/e-smith/templates/httpd/vhost-default/30SOGo /etc/e-smith/templates-custom/httpd/vhost-default/
    sed -i ‘/ProxyPreserveHost/d’ /etc/e-smith/templates-custom/httpd/vhost-default/30SOGo
    signal-event nethserver-sogo-update

/cc @Greg @alefattorini

It works like a charm, just tested on another installation :thumbsup:
Sogo still works correctly