7.8.2003 Upgrade works but UI still says 7.7.1908

It’s the same problem as the one from @transocean

EDIT! I also installed the new version now, I have the same behaviour.

cc @dev_team


I’ve just checked about two-thirds of my 20-30 NethServers, all now running 7.8.2003.

All display Version correctly in Cockpit (Before and after Log-In), and also in the older Dashboard.

So this seems to be a sporadic problem, depending on a circumstance (to be found)…

cc @dev_team

My 2 cents

What is the content of the file /etc/nethserver-release

If you look @ the screen-shot it states correctly it is NethServer release 7.8.2003 (final) . AFIAK there the contend of /etc/nethserver-release is shown.

I suspect the browser cache…
(if you want to switch the language of cockpit it often gets a mismatch of two, cleaning the browser cache resolves this… hence the hunch)

NethServer release 7.8.2003 (final)

After cleaning the cache I had the same behaviour as before. After that I did a flushdns, what shouldn’t be important, because it’s only the dns cache. Then opened the site by name and not by the ip and I had the right version. Cleaning browser cache again and opening the site by ip again, now shows the right version.

Cockpit and the browser cache that information.

After cleaning the browser cache, usually systemctl restart cockpit is enough.

1 Like



Are you using FireFox?

As mentionned: FireFox sometimes acts fussy, especially when SSL is concerned…

Note: FireFox IS my standard Browser, if possible, on all platforms.
I do keep a second Browser for double-checks… :slight_smile:

My 2 cents

Tried with Firefox and Edge (old Version).

1 Like



SSL stuff should always be checked with DNS name first, at least if using stuff like LetsEncrypt.
AFAIK, it’s not possible to get a correct SSL with LetsEncrypt for internal IP adresses (this info may have changed…). Most NethServers will be using an internal IP adress, IPv6 isn’t yet supported.

Nonetheless, it should also work with IP…

For me it’s a self signed certificate created by nethserver.

There was no problem to open the address, it only shows the wrong version number.

It isn’t possible to get a cert from Let’s Encrypt for any IP address.

1 Like

My report was based on using Chrome. I tried Firefox and new Edge (an adaptation of Google’s open source Chromium), and those display correctly.

Suggestion: remove the version number from that page. I dont see complaints from other UIs and programs that require you to go to “About…” somewhere to see the version, and since this isn’t a reliable source of truth, why bother?

Congratulations on a smooth upgrade, which is what really matters.

We can’t do it: that part is from upstream, you can try open a issue on GitHub page of Cockpir project.

IMO is a minor glitch :slight_smile:


YO is correct. It is a minor glitch. FWIW, in Chrome, I cleared the cookies for the site (1 cookie) and it still fails, but it works in new Edge and Firefox, so I am not going to worry about it.

In my idle curiosity, i might do some spelunking to understand how you pass that parameter to Cockpit. on the face of it, I am sure if it wasn’t a minor glitch, you could find a way to eliminate it.

Thanks for answering me.

IIRC Cockpit parses /etc/os-release file, but I never digged into the upstream code for this part.

FTR, Cockpit-217 on Fedora 32 does not show the distro version, neither on the login page nor in the top left corner.

1 Like

TY for pointing that out. I am working with a team that is considering using Cockpit for a different use case where the software stack is a.mishmash of subsystems that would not be identified by one release number, so it would be better to not have it shown.

As @giacomo said, the file is /etc/os-releasein particular the key VERSION. If you try to check the content of that key you should see the correct system version.

If you try to change it, save the file and execute systemctl restart cockpit then Ctrl+Shift+R to hard refresh the cockpit login page, you should see the same version.

Have you try it?

PS. that file is a NethServer template: /etc/e-smith/templates/etc/os-release/10base