Yum rpmdb failed

NethServer Version: 7.4 beta 1
Module: yum

I installed 7.4beta1 in an VM on Proxmox. Updated the base installation and then installed some modules (Firewall, Webfilter, NDPI, Suricata, Evebox, Proxy, Samba, NSDC, SOGo, email, Backup, Ntopng, CGP, MySQL, OpenVPN, Webserver).
When I go to softwarecenter I got this:

I can’t install any module or see which were installed allready.
Clicking on the button didn’t help. Also a yum clean all didn’t help.

so I did:

rm -f /var/lib/rpm/__db*
rpm --rebuilddb
yum clean all

Now yum works again correctly.
Don’t know if this is related to V7.4b1. Just wanted to report it, because we’re in beta-state.

Cheers Ralf

1 Like

Hi @flatspin,

I had the same issue, installed some packages after fresh install of the new 7.4 beta 1:

Another screenshot of the error:

I just clicked on Applications, then on Software Center again and it worked without rebuilding rpm db. I remember, I also had this error from time to time with NethServer 7.3.1611 but I ignored it because it was a heavy tested system and Software Center worked anyway.

1 Like

I will try to reproduce it.


This worked for me too.

rm -f /var/lib/rpm/__db*
rpm --rebuilddb
yum clean all

I know it’s an old post, but I had same problems with the final 7.4.1708.

rebuild the db works too.

1 Like

Do you have a local AD accounts provider?

BTW this is the full, official procedure


Hi Davide,

this post is more than 6 month old and was about NS 7.4 beta 1.
Thanks for the official procedure. Good to know.
I had NSDC with local AD installed that time.
But maybe you were asking @m.traeumner ?

1 Like

Yes I have a local AD.

1 Like

same problem with local AD

i got a similar error today with error

   [root@monit ~]# yum update -y
    error: rpmdb: BDB0113 Thread/process 4031/140081327101760 failed: BDB1507 Thread died in Berkeley DB library
    error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
    error: cannot open Packages index using db5 -  (-30973)
    error: cannot open Packages database in /var/lib/rpm

    Error: rpmdb open failed

the instructions above hlped clear the issue bu i am not sure what happened before that.

I guess, it’s because of an interrupted installation.

1 Like

Sorry for late response. Didn’t had time yet.
I think @mrmarkuz is right.

1 Like