Yum autoremove strange behavior

yum

(Thorsten) #1

NethServer Version: 7,5
Module: via shell

I do not not if this might match to

however I hadt some strange behavior of yum autoremove in the night from Fri Aug, 17th 2018 to Sat, 18th, 2018: It repored to remove 126 packages and stoped working in the miiddel. ]CRTL]+c repored some failures / suck. I track this back as I installed urbackup from stephanedl respiratory and removed it after some houres of trail.

yum also reports that rpkg file was changed manually (which I did not).
The system itself seems to be stable, but Is there any idea / or need to repair?

THX
Thorsten


(Markus Neuberger) #2

Does it work if you run it again?

Did you install something with rpm instead of yum?

yum clean all should fix it.


(Thorsten) #3

Hi Markus,

I had to repeat three or for times until it worked without getting stucked. However it reports

Skipping unreadable repository ‘/etc/yum.repos.d/subscription.repo’

Which I think is normal, isn’t it?

no, I just installed stuff from stephdl and fish on my produtive server. fish worked through yum as well. I did that a few days ago and already run yum autoremove.

did that, thanks for tip and further reading.

THX
Thorsten