Why not Kernel 4.x?

I want to try NethServer with my ZOTAC ZBOX CI327 NANO. But I need Kernel 4.x for the Apollo Lake CPU with a new Realtek network driver. Why do you use such very old kernel?
Regrads, Marko

It’s upstream (CentOS/Red Hat) default choice to keep well proved kernel, backporting security patches and some features of higher kernels.

From Wikipedia:

To maintain a stable application binary interface (ABI), Red Hat does not update the kernel version, but instead backports new features to the same kernel version with which a particular version of RHEL has been released. New features are backported throughout the Production 1 phase of the RHEL lifecycle. Consequently, RHEL may use a Linux kernel with a dated version number, yet the kernel is up-to-date regarding not only security fixes, but also certain features. One specific example is the SO_REUSEPORT socket option which was added to Linux kernel 3.9, and was subsequently backported and became available since RHEL 6.5, which uses version 2.6.32 of the Linux kernel.

However, there’s the option to use a more recent kernel using a repository like ElRepo. I might be wrong, but think some specific features of NethServer might not work (i.e. IPS).


AFAIK, the 3.10 kernel used by Red Hat (and Nethserver) supports Apollo Lake.

Using an elrepo kernel you will lose only ndpi (deep packet inspection). But the ndpi module can be build for elrepo (I know it works perfectly).
The IPS works in user space.


Thanks for correction, I didn’t recall it was ndpi.

The ZOTAC Support says “no”. I need a 4.x kernel.
I tried to install NethServer 7.4 on this appliance, but the installation hangs. :thinking:

Thank you for all answers. But i don’t a chance to install NethServer. That’s sad, because the system looks very interesting for me.
…and the active and friendly community too :1st_place_medal:

best regrads, Marko

1 Like

You could try to install a CentOS Minimal System, there are also howtos at the web, which tell how to build a custom iso. So you can implement an other kernel:

If it works you can install nethserver on CentOS



Another option I am using is I have Nethserver working as a VM within Proxmox. Nethserver is providing OpenVPN services for a few users and after some initial learning seems to be running pretty good. My CI327 Nano is running with 16 Megs of Ram. I tried both the install on CentOS 7 and the *.iso install and both worked.

With Proxmox there was some fiddling to get the intel wireless card running. My wireless card presents the Proxmox user interface and the two wired cards are for the VMs.

Seems to be working but it has only had 3 days of up time at the longest stint over the last week because I was futzing with set up.

This could be an option for you.


For The Record:


Hello, MArc,
Your hint was the basis for a successful installation on the ZOTAC ZBOX CI327 NANO.
What have I done:

  1. installation of Centos 7.4 with kernel parameter “intel_idle. max_cstate=2” when booting from USB stick
  2. install ELPRO kernel according to this manual: https://elrepo.org/tiki/tiki-index.php
  3. activate Elpro kernel ML according to this manual: https://elrepo.org/tiki/kernel-ml
  4. Set new kernel as default: https://wiki.centos.org/HowTos/Grub2
  5. reboot the system and enjoy an unprecedented fast system (before a boot process took 10 minutes, now 10 seconds)
  6. NethServer installed via Netinstall
  7. interfaces green/red adapted and DHCP configured to green
  8. new call of Service Manager from a client to GREEN

Thanks for the tips!

Now I just need help installing deep packet inspection in the user space.

Perhaps this approach will also help other users.
Best regards, Marko


Maybe these steps could be added into Wiki as an “working howto for recent hardware”.


Good advice, would you mind creating a new page on the wiki? @dnutan and @capote may help you.

I think that such a page will be obsolete in a few months. Red Hat regularly updates the kernel to add support for new hardware.

I think that you made a good point.
But for RedHat perspective, a good release is “one that works”, not “one that comprehends everything”. Therefore the steps listed by @capote could help someone understand if his hardware could work on more recent kernel, even hardware updates are still not backported by developers on supported RedHad kernel.

I am thinking, for instance, on Ryzen-Based embedded APU by AMD, far more interesting than G-Series. Or Gemini-Trail.
I know, most hardware still not on market, but in few months some things will arrive… Without Spectre and Meltdown companions.

1 Like

Additional Experience: The last system update via Service Manager fails today: The system is completely inoperative. I’m installing new…

-new packages (a long list) where announced inside the Software Center- after a round about 20% progress a massage came like: “No response of the browser window- reload or try again?”

  • Reloading the window
  • now GUI response
  • no SSH -answer
  • no ping answer
  • no traffic forwarding
  • hard reboot
  • WebGui came up
  • System was reachable
  • all trails to deal with software packages fails with “YUM Error”
  • all trails to restore any backup are faild with same “YUM Error”

    I have to install new :frowning:
    Regrads, Marko

Ps.: and now the installation fails after rebooting with …
nethserver login: [100.176248] iwlwifi 0000:01:00.0: capa flags index 3 larger than supportet by driver
During pre-installation/configuration I deactivated the wifi-interface, because no need