What process runs every 30 minutes


(Eddie Atherton) #1

I have a pool of drives, using MHDDFS, with a number of directories which are then shared using Samba by mounting the pooled directory, with bind, with the /var/lib/nethserver/ibay directories as mount points. This is working perfectly for what I need.

I have set the drive spin down time to 20 minutes using hdparm. But, it appears that there is a process that runs every 30 minutes that is waking all my drives from sleep 10 minutes later, without fail.

What process is this. I haven’t been able to find anything related to cron doing this.

Cheers.


(Artem Fedai) #2

Hi @EddieA ,

please check /var/log/cron and /var/log/messages


(Eddie Atherton) #3

The only entries in /var/log/messages are from dnsmasq-dhcp.

The /var/log/cron shows jobs running every hour, not every 30 minutes. Most of them run at hh:01 apart from a clamav job that runs at hh:45. The process that spins up my disks runs at hh:22 and hh:52.

Cheers.


(Alessio Fattorini) #4

Check also cron.d


(Eddie Atherton) #5

There is no indication of what’s running in either /var/log/cron or in any of the files/directories that I can see which are included in cron.

I can find no cron jobs that run either at a 30 minute interval or at hh:22 and hh:52.

Cheers.


(Artem Fedai) #6

@EddieA you can run iotop and see what makes disks spins up :smile:


(Filippo Carletti) #7

Another option is block_dump, see http://www.linuxinsight.com/proc_sys_vm_block_dump.html

sync
echo 1 > /proc/sys/vm/block_dump

When the disk wakes up, use dmesg to see what caused activity.


(Eddie Atherton) #8

@filippo_carletti
That’s exactly what I did last night to try and trace this. But nothing was logged. :astonished:

But, since then the mystery has been solved: smartd. Which wakes up every 30 minutes to check the status.

A quick change to the smartd.conf to “let sleeping disks lie” and now they stay in standby state until it’s time to actually read/write to them.

Cheers.


(Artem Fedai) #9

@EddieA I have only VM environment so smatrd i can not detect , share pls smartd.conf changes for all community.


(Eddie Atherton) #10

I just added “-n standby,q” to the DEVICESCAN directive.

Cheers.