Webtop no login page, download 0Kb file

Good morning,

this morning I found myself a nice surprise …
Webtop no longer works on my personal server.
The problem is the following, the login screen no longer appears, but when I get to the page where the login should be, it downloads an empty 0Kb file.
All the rest of the mail server is working fine. To remedy the problem, I temporarily installed SOGo.
Immediately I thought about a version / update problem and I re-installed the previous version (I didn’t think about it),
but still not working, I looked at the logs and the problem seems to be postgreSQL inconsistency.
How can I save the configurations and settings made on the webtop, re-install postgreSQL and re-load the configurations?

If this is not possible how can I reconfigure it to factory settings?

Could you please share the relevant log entries?

Do you have a backup? Does a dump of the db work? Following example dumps the db to /tmp/backup.sql. It could be restored later.

su - postgres -c "pg_dump webtop5 > /tmp/backup.sql"

If the dump worked you may try to repair postgresql. You could also check/manage your postgresql installation with phppgadmin.

To reset webtop to default it should be enough to remove the db and reconfigure Webtop:

Stop service to allow removing the db:

systemctl stop tomcat8@webtop

Remove DB:

su - postgres -c "psql -c 'drop database webtop5;'"

Reconfigure webtop and start services:

signal-event nethserver-webtop5-update


I love you!!!

this was the solution:
Database dump

su - postgres -c “pg_dump webtop5> /tmp/backup.sql”

recovery of webtop5

systemctl stop tomcat8 @ webtop
su - postgres -c “psql -c ‘drop database webtop5;’”
signal-event nethserver-webtop5-update

database restore

cat /tmp/backup.sql | su - postgres -c “psql webtop5”