Webtop issues and setup questions

webtop5

(Charles) #1

NethServer Version: NethServer release 7.3.1611 (Final)

Module: Webtop 5

Hello @webtop_team,

  1. I’m trying to use the Public folders in my Webtop 5 for our office. In Public I right click to create a new folder we can all see. I give this folder a new name but upon pressing Ok I get a box with a big red X and no message. I’ve tried editing the security (Managing Sharing) but again I don’t have the proper access. Please provide the steps I need to enable public folders for sharing with our office mail accounts.
  2. Is there a setting to autosave mail automatically when writing an email. Our Zarafa had this feature enabled so after a few seconds of writing your email it was automatically saved to draft for us. If we sent the email the draft was removed. Or like in Gmail where it auto saves your email as you are typing.
  3. I had a strange issue with composing an email whereby I clicked on the Address book but I couldn’t find any contacts in my addressbook (and we have 10 email accounts on our Nethserver using Webtop 5). After typing in names into search and not finding any contacts I pressed Save and Close. Upon returning back to my email message compose screen my To: field was completely missing. What would have caused this issue. And why would my account not have access to all addressbook contacts by default?
  4. I believe there was comment made a few months back to allowing us to connect our Webtop 5 cloud to our Nethserver Nextcloud. What is the status of having this available?

Thank you.


(gabriele_bulfon) #2
  1. Hi, I bet you stumbled upon a Dovecot bug around shared folders. @giacomo can you check if this case is similare to the rename bug on shared folders?

  2. Automatic save is done by the message window automatically, but not in drafts. If you accidentally crash the browser or exit, you will get back your message once logging in.

  3. At the moment, the directory of users is not looked up as a contacts directory, you will have to create a group user (e.g. “name of the company”) and share it to all users, then load contacts in it.
    The empty recipients list case is a bug, I added it here : https://redmine.sonicle.com/issues/252

  4. This feature is on the roadmap, not implemented yet

Gabriele


(Giacomo Sanchietti) #3

I don’t think so.

@greavette could you please try to do the same with roundcube? If it doesn’t work neither in roundcube it’s a bug in dovecot itself.


(Charles) #4

Hello @giacomo and @gabriele_bulfon (@webtop_team),

Sorry for the delay in getting back to you on my testing. I’ve installed Roundcube and in settings tried to create a new folder under Public Folders. I’m getting the same permissions error on Roundcube like I did in Webtop:

Unable to create/move folder into selected parent folder. No access rights.

Looks to be a dovecot bug then. What’s the fix to get this resolved in dovecot?

Thank you.


(gabriele_bulfon) #5

Nice to know it’s not a Webtop bug! :wink:
I believe there are ACL problems on that folder, or a different version of the rename bug of Dovecot.
@giacomo may help on this


(Giacomo Sanchietti) #6

AFAIK there is no fix. Am I right @davidep?


(Charles) #7

Oh oh…we use public/shared folders daily in our office. If these don’t work I know I’ll get pushback on being able to move to using Webtop. I’m hoping there is a fix available. :slight_smile:


(Giacomo Sanchietti) #8

The only limitation I see is that you can’t rename shared folder, not a big IMHO :slight_smile:

Please note that this not a bug in NethServer nor WebTop, but it’s an upstream issue.
I even hardly call it a “bug”: I guess Dovecot is not designed for such scenarios.


(Charles) #9

Hi @giacomo, sadly it’s not that simple. The problem is I can’t create folders in Public at all from the WebTop GUI. If this is a permission issue, is there a way to create a folder from the terminal perhaps and grant permissions to Webtop to get around this problem?

Thank you.


(Giacomo Sanchietti) #10

I probably didn’t understand well your use case.
Could you describe it with an example?

By the way, if you’re trying to create a public folder, you must go to the web interface of NethServer:

  1. create a group for all users which need to receive the mail
  2. go to “Email addresses” -> “Shared mailbox” -> “Create new”, and create a new shared folder, also tick “Create alias” to create the associated pseudonym

Example:

  • Create users “goofy” and “giacomo”, added them to “helpdesk” group
  • Create a shared folder “support” with associated "support@domain.com" pseudonym

(Charles) #11

Hello @giacomo ,

This is getting me closer to what I need…but a few more details are missing for me to fully implement this. :slight_smile:

Is this the only way to implement shared folders in WebTop? My users are used to from Zarafa creating folders from within the mail client and assigning. Am I able to modify settings in such a way so that my users can create shared folders directly from WebTop…or will my users need to request from me (the Admin) to create all their shared folders ahead of time in the Nethserver GUI?

Secondly…you’re example has helped me create a parent folder under Public now so we can move/copy mail into this public folder. But how do we add subfolders? We currently have on our Zarafa roughly 50 folders under Public (shared) and under each of these 50 we have more subfolders (and folders under those subfolders). How do I do this? I again tried from the Webtop Interface but received a permission denied error so I’m assuming I need to create sub folders from the Nethserer GUI…how can this be accomplished?

Thank you.


(Charles) #12

Hi @dev_team and @webtop_team,

I’m following up on my question asking for how I create subfolders under Public Folders. I’ve been successful in creating a Public Folder from Nethserver. But I don’t know how to create subfolders. The nethserver server isn’t intuitive how to create a folder in a folder. And from WebTop GuI I get an access denied on creating folders in the Public folder. I’m stuck.

Any help would be greatly appreciated.

Thank you.


(Alessio Fattorini) #13

I may suggest you another way, creating all that folders-subfolders under a generic account and sharing all of this through the webtop sharing option


(Giacomo Sanchietti) #14

I just successfully created 3 subfolders on a public folder using 3 different clients:

  • Thunderbird
  • Roundcube
  • Webtop 5

Of course, you need to be inside the owner group of the folder.

By the way, after creation of the folder, Dovecot doesn’t allow to remove it.
I can’t find any information inside the logs, but the subfolder has following ACLs:

[root@nethservice ~]# doveadm acl get -u giacomo@nethesis.it Public/redmine/t3
ID Global Rights
group=redmine@nethesis.it create expunge insert lookup read write write-deleted write-seen

Maybe @davidep has some suggestion on this behavior, but this not strictly related on what you are looking for.