Webtop - issue creating task


(Jesus Campos) #1

Hi,

I’m not sure if this issue has been reported or solved yet in other part of the community.

I have a practically fresh instalation of nethserver running other services like rspamd, nextcloud and webtop.

In webtop i have running without issues, calendars, contacts and email, but when I create new task i got an error!

I let you some images of the error notification and some logs, in this logs i see a problem in the database, but i don’t have idea how to solve it.

So, i’m really appreciate if someone help me to fix it.

Regards!


(Luca Gasparini) #2

Hi @jcampos,
if you can show me what is written to the log when you access the Tasks I can try to help you.

You can also show me the output of this command:
su - postgres -c "psql webtop5 -c \"select value from core.settings where service_id='com.sonicle.webtop.tasks' and key='manifest.version'\""


(Jesus Campos) #3

Hi @lucag

I’ve updated the post, and here is the output of the command.

Thank you!


(Luca Gasparini) #4

Ok @jcampos,
the problem could be due to a failure of the update procedure on the tasks.tasks table during the installation of the last release.

If the problem is this you should resolve with a downgrade of the version in the manifest:

su - postgres -c "psql webtop5 -c \"update core.settings set value='5.2.2' where service_id='com.sonicle.webtop.tasks' and key='manifest.version'\""

and a restart of the application:

systemctl restart tomcat8@webtop

Let me know if you solve the problem :wink:


(Jesus Campos) #5

Sorry, but the same error appears again after the command execution and the tomcat service restart.

I execute the command

su - postgres -c “psql webtop5 -c “select value from core.settings where service_id=‘com.sonicle.webtop.tasks’ and key=‘manifest.version’””

and as you see, the output is 5.3.0

After that, I execute

su - postgres -c “psql webtop5 -c “update core.settings set value=‘5.2.2’ where service_id=‘com.sonicle.webtop.tasks’ and key=‘manifest.version’””

and the system go to “Maintenance mode”, and the version now is 5.2.2

But when I apply the tomcat restart command the system go out from Maintenance mode and the version again is 5.3

¿do you have another idea?


(Luca Gasparini) #6

Hi @jcampos,
:thinking: then it is likely that only some queries failed after the previous update.

Check what the “DB Upgrade” page you find on the WebTop admin panel shows:

It is probable that in your case there are queries that have not been executed regularly and that you have to advance manually.

Can you paste a screenshot of what you see on this page?


(Jamie Langer) #7

Details about what’s in the log would help people answer to solve your query


(Jesus Campos) #8

Here is the screenshot of the same db section in my webtop interface


(Luca Gasparini) #9

Ok @jcampos we found the problem and this would be the solution:

  1. put in maintenance the application by clicking on the top left button “Maintenance not active”
  2. select the line (the one that shows the first ERROR) and click on the “Skip” button at the top
  3. select line 2 and click on the “Run” button to have the queries performed on hold
  4. should stop at the next error on line 8
  5. at this point you can “Skip” all the following queries since they are the replication of the previous ones
  6. disables maintenance by clicking again on the left-hand top button

In this way you should solve the problem you are encountering on the Tasks.

Let me know :wink:


(Jesus Campos) #10

@lucag Sorry but it doesn’t work

I follow all the steps and the system still show me the error notification!

Here is the DB Upgrade section with the new outputs


(Jesus Campos) #11

@lucag I’m going to mark this issue as solved.

Thank you very much for the support!

Here is the way to do it! :slight_smile:

After that I follow the steps that you mention.