Webtop Contacts

webtop5

(Wayne Bilger) #1

New install of NethServer and Webtop, users are created on the NS AD DC
One of my users can create contacts and nothing shows up in their contacts. If they start typing in email they find the contact, but nothing to see or select in address book. If I import, and overwrite, it says it is going to overwrite 30 contacts, so they are there. Weird thing, is if another user shares contacts with this user, then can’t see those either, but again, can see them autocomplete in email.
If the user (who can’t see contacts) shares their contacts with others, the other users see the shared folder, but then they also dont’ see the shared contacts, but do see them in email autocomplete.


(Federico Ballarini) #2

If I understood the problem is that you can’t see contacts in Webtop “Contacts” page, but only in autocomplete mode?


(Wayne Bilger) #3

The user can’t see the contacts in their contacts page, but if they are sending an email, in the To or CC BCC sections and they start typing the contact name, autocomplete finds the contact, so I know they are there.


(Federico Ballarini) #4

Strange… I use webtop and can’t replicate the problem… it’s up to date?
Could you post a contact page screenshot?


(Wayne Bilger) #5

It is very strange, and it is just one user. Just picture a blank contact page, that is exactly what you see, not much to screen shot. It just says “No Items to display”. If you share with this user, you see the folder, but looks like nothing in it. I have rebooted, no change.


(Saito Benkei) #6

Can you check if in “grouping” you selected “contact list”? If so, try changing it to “Home” or “Business”.


(Jay Gummers) #7

Yes, agreeing with Saito on this, you should change the group either one of them and it should work after that.


(Wayne Bilger) #8

Grouping was set to Contacts list. Tried all other groupings, nothing, still just “No items to display”. But, contacts are there for sure, just hidden somehow. Is there a way to delete this users webtop data and start over? It is a NethServer AD user.


(Saito Benkei) #9

Can you try deleting and re-entering contacts, maybe trying to insert them by hand?

To delete the contents of your address book, try this way:

Create a text file with the extension .ldif with some random characters inside (just one) (for example empty.ldif)

Right-click on the address book and select “Import contacts”.

Select “LDIF” and then “Next”.

In “Import from” select the empty flie ldif (e.g. empty.ldif) and then “Next”.

Select “Copy” and then “Next”.

Select “Start”

This deletes all existing contacts in the address book and imports those in the LDIF file that do not actually exist.


(Wayne Bilger) #10

Didn’t work. It deleted all the contacts, but if I add a new on, or import, nothing shows.
I think I need to delete their webtop data, where is located? This is the only user that had contacts in a test system and I rsynced the vmail folder only. Can’t be a coincidence as this user is only user it’s doing this to, and webtop had this user account already enabled after the fresh install (green check mark in users in admin settings).