Webtop Contacts default address book

Wondering if there is a way to set the default address book for Webtop users.
I have a shared “Company” address book, and I want it to be selected by default when any user who has access clicks the New Contact button.
Right now, it defaults to their personal address book, or, if the shared address button is clicked on, then you click “New” then it defaults to the shared address book. I know that in this scenario, many users will create new contacts thinking they are creating them in the shared address book, and they will be in their personal.
Same with Calendar really, it behaves the same.

In calendar (also shared) you can right-click on calendar name and then check “Default”

Same behaviour in shared addresses books.



Yes, that is exactly what I have, and it does not work, always defaults to the Personal Webtop address book.
The only way it defaults to the shared address book is if you expand the Users of the share, and click on the shared Category. Then next login or refresh it defaults back to the personal address book.
Same behaviour for Calendar.

1 Like

Yes, you are right. It doesn’t work. I’ll update Webtop Team :slight_smile:
It works only because you have selected shared calendar with one click on it and not because you have checked “Default” option.

1 Like

Correct, and thanks.

I think it is necessary that @gabriele_bulfon or @matteo.albinola help us to better understand how the “Default” setting works on Calendars and Contacts and if it is usable also for shared resources.

Can you explain his function here ?
Thank you :wink:

You should be able to select the Shared address book, or calendar as the default, so that any time you click “New” contact or appt. in calendar, it defaults to the Shared calendar. This is essential for company groupware. If it is not default, users will often not notice that their own address book is where the contact is being created.
One thing to note, if the shared Address Book shares all of the Elements permissions (create, update, delete), but only the Read Permission for folder (which is what you want I think so noone accidentally changes the folder name etc), you cannot edit the shate, so therefore cannot select Default (which right now does not work anyway). All you can do is click on your personal address book and De-select default. The shared should be selected as Default by the user that shared it.

“Default” check on shared calendar has no effect on default selection of calendar. It works only with your personal calendars.

I feel there really needs to be a way to make a shared calendar the default, this is a company groupware, in most cases, personal address books are not used.