Web Filtering Category disappeared


(Alessio Orizio) #1

Hi all,

i have a problem with the Web filtering components.
I’ve configured Nethserver to work as transparent proxy and after default filter configuration and downloading/installing Shalla blacklist everything are ok.
The clients that use Nethserver as gateway have http navigation filtered like a charm.
I noticed today and yesterday on the web filtering configuration that all the content of categoryes are disappeared.
I have re-downloaded and re-installed Shalla Blacklist and then the list of categoryes is present.
The problem is that while the categoryes are disappeared the web filtering doesn’t work and the blocked content are not blocked.
I ask if it’s right re-install everyday the blacklist or i have some kind of problem in my installation.

Thanks for the support guys !


(Alessio Fattorini) #2

It looks odd, never seen it happen. Maybe @giacomo @davide_marini @filippo_carletti have some hints in this regard.


(Giacomo Sanchietti) #3

I never saw this problem, but in theory it could happen if the cron script can’t download the blacklists.

This is the relevant part:

We could fix it by doing the blacklist update job inside a temporary directory, but it’s not an easy job.


(Alessio Orizio) #4

Thanks guy,
but after i thought really about my problem i’ve found the reason of this disappearance…

I’ve a firewall, through which the Nethserver Gateway goes outside…but i’ve scheduled a block of internet connections on the night time.
I suppose that the cron job works on night time…is it right ? How can i check when the cron job is executed and change it?

I know i’m a difficult person :smile:

Thanks for the support !


(Alessio Fattorini) #5

I suppose correctly! :smile:
You’re looking for this

/etc/cron.daily/squidGuard

but I would suggest you create a bypass on your firewall only for NethServer


(Giacomo Sanchietti) #6

No, the right script to check is /etc/cron.daily/update-squidguard-blacklists.
It’s executed once a day during the night, take a look to this page for a better explanation:

/cc @acsel10


(Alessio Orizio) #7

@giacomo

Ok i’ve tried to set in /etc/anacrontab the interval of job execution as 07.00 am - 22.00 pm.
I hope that help me !!! Tomorrow i’ll check if it’s the right solution to my problem…

Thank you


(Alessio Fattorini) #8

How was it going? Did it work? :smile:


(Alessio Orizio) #9

Yes, it works. Yesterday with the problem of shallalist it didn’t work. Using urlblacklist in the last night it worked and update the blacklist.

Thanks all for the support !