Web filter Blacklists sources not reachable


(Alessio Orizio) #1

Hi all,

my Nethserver can’t reach the Blacklists from the sites designed in the /etc/cron.daily/squidGuard…

It says can’t resolve “ftp.teledanmark.no”. And for the other wget, which is related to “ftp://ftp.univ-tlse1.fr/pub/reseau/cache/squidguard_contrib/adult.tar.gz” it stucks in some operations and doesn’t downloaded the package.

With other sites no problem, it works!!!

How can i have the blacklists back to work ? I ask you DEV a check, please.

Thank you !


(Giacomo Sanchietti) #2

The script you’re talking about is disabled in NS installation.
Have you enabled it by setting ENABLED option to 1?


(Alessio Orizio) #3

OK…the option is 0 so it’s not the right script.
Otherwise i’ve a problem, when i’ve tried to download and install a new blacklist the UI stuks in the 50% phase and doesn’t finish the process.
In this way the filter that i’ve configured seems doesn’t work.

What i’ve to do ?

Thx


(Giacomo Sanchietti) #4

Just execute this script and check where it hangs /etc/cron.daily/update-squidguard-blacklists.

You can execute also with debug:
sh -x /etc/cron.daily/update-squidguard-blacklists


(Alessio Orizio) #5

This is the output:

  • BLPATH=/var/squidGuard/blacklists
  • BLFILE=/var/squidGuard/blacklists/blacklists.tar.gz
  • URLFILE=/etc/squid/blacklists
  • DEBUG=0
    ++ date +%s
  • tot=1457960623
  • ‘[’ ‘’ == -d ‘]’
    ++ pwd
  • curdir=/etc/squid
  • ‘[’ -d /var/squidGuard/blacklists ‘]’
  • ‘[’ -d /var/squidGuard/blacklists.old ‘]’
  • rm -rf /var/squidGuard/blacklists.old
  • mv /var/squidGuard/blacklists /var/squidGuard/blacklists.old
  • mkdir /var/squidGuard/blacklists
  • ‘[’ 0 -eq 1 ‘]’
    ++ /bin/grep -v -e ‘^#’ -e ‘^$’ /etc/squid/blacklists
  • for url in ‘/bin/grep -v -e '\''^#'\'' -e "^$" /etc/squid/blacklists
  • download_extract http://www.shallalist.de/Downloads/shallalist.tar.gz
  • ‘[’ 0 -eq 1 ‘]’
  • verbose=–quiet
  • wget --quiet -O /var/squidGuard/blacklists/blacklists.tar.gz http://www.shallalist.de/Downloads/shallalist.tar.gz

In fact shallalist.de is not reachable…i’ve just only to wait ???


(Alessio Orizio) #6

I’ve solved using urlblacklist ( commerical ).
Shalla doesn’t work at moment, just a notice.

Thx for the help