VPN server to the local LAN

:smiley: :+1:

I think it’s correct.

hmm have now done that but I can’t connect to anything?

I can now connect with a client from a ipad to my VPN server and I can see in the status in nethserver that is connected. I also have a green light in the client in the iPad and the server have give the client 172.16.0.6.

But I can’t even ping the VPN server that is connect to?? (192.168.0.35)

I have enable roadwarrior server
I have select “Username and password”
I have select "Routed Mode (Network: 172.16.0.0, Netmask: 255.255.255.0)
I have select under the routed mode advanced “Route all traffic through VPN”
I have under advanced select both "Enable TZO cinoression and “Push all static routes”
Under DHCP options I have set DNS to 192.168.0.1 (Routerns DNS server)
And the UDP is 1194

You trying to ping the hostname of the Nethserver or directly the IP of the server?

Try putting in the DNS field the Nethserver IP

Remove LZO Compression and Route all traffic through VPN

If your iPad is in the same lan/wlan of the Nethserver probably the VPN doesn’t work

Thanks for the fast replay

I have remove LZO Compression and also Route all traffic through VPN
I have set DNS to 192.168.0.35

I did try to ping from the iPad with the IP number both 192.168.0.1 (Routern) and 192.168.0.35 (Servern) same result, no response.

The ipad is connect to 4G thru my mobile so

iPad - My mobile - 4G - VPN servern

/Update
Have look inside the clients log
When I do trying to access a webpage thru the VPN it just loading and loading until it get a timeout

“Session invalidated: KEEPALIVE_TIMEOUT”
“Client terminated, restarting in 2000 ms”

after that it reconnect to the VPN servern

Let’s try to access to Nethserver default web page via ipad after you estabilished the VPN Connection:

http://192.168.0.35

(Maybe the ping doesn’t work but I don’t think, it’s only a test)

mm I did try that

https://192.168.0.35:980

Just loading and loading.

The strange is I have done this before when I first time did try nethservers VPN server and I did can connect to VPN and did ping (even SSH) VPN servern but that all.
Now I just can connect so I maybe delete the server again and create a new one.
I did follow this guide

Excuse me for the question:

Did you download and install the .ovpn configuration file on the client after making the configuration changes?

hmm well no not after the last Changes?

Very nice.
I have almost got it to work when I did download a new config file

I can now ping the local network and access that I want.

But I can’t go out on internet thru VPN.

I guess that I have to create a static route in the router but instead go LAN it have to go WAN??

Now try checking “Route All Traffic through VPN” and download the configuration file again.
You can try to check “LZO Compression” but I’ve had some issues with this option checked.

Tip: If you use OpenVPN client on Windows, start it in administrator mode (click with right butto of the mouse on the OpenVPN icon -> Start as administrator) otherwise OpenVPN fails to create the correct routes.

“Route All Traffic through VPN” is already on

Do you mean “Push all static routes”

Also do I need to create a Another static routes in the routern to connect to internet?

No, “Push all static routes” should be unchecked

“Route All Traffic through VPN” is under “Routed” -> “Advanced”

I don’t think there’s any more static routes to create.

is already checked.
I most have forgot to unchecked the settings :slight_smile:

Hmm ok, well I can now access and ping the LAN but not the WAN at all.

You can try a

traceroute www.google.com

to see what path the packets take, but I don’t know is there’s a tool like traceroute on iPad

The first step is 172.16.0.1 after that is give me timeout

ohh now when I’m home I running the OpenVPN client on windows 7 machine.
Thanks to the idea to use Another client I have now easy access to the remote LAN thru VPN

So when I run “tracert www.google.com” I get only one jump and that is to 172.16.0.1
same result even when I trying with “tracert 8.8.8.8” so it is no DNS problem.

I did try for fun to use putty to connect to the nethserver and from there do a ping and when I do that everything looks nice.
So it is the client machine that have no access out to the internet, only the remote LAN.

does anyone have any suggestions? @support_team

I didn’t follow the whole topic but as far as I understand you can connect to the VPN server (Nethserver) and you can ping it. But you cannot reach anything that is behind it.
My first thought is: Firewall issue? Do you have a firewall installed on the Nethserver? What happens if you (temporary) allow everything from and to your VPN-Range?

The OP reaches all devices in the remote LAN via VPN (Nethserver, various devices on the LAN).
He wants to use the VPN to route all internet (navigation, etc…) to the remote LAN, but it doesn’t seem to work.

Should this be a permanent solution our just temporary when the VPN is connected?

You can add a route to 0.0.0.0 and using the VPN Server as gateway. In that case everything should be routed to the VPN Server.

One thing to keep in mind: Also add a route to the VPN Servers IP via your regular gateway. Otherwise you cannot reach the VPN Server anymore.

This should already be done automatically on the client when the VPN connection is established if it has been flagged “Route All Traffic through VPN”.

There is some personal firewall installed on the client?
Can you disable it?