VPN package does not install as expected


(Adam) #1

I installed VPN and left samba unchecked:

Then if I click “edit” on the VPN package, samba is present:

I unchecked samba and clicked apply settings, and then although VPN is installed and showing up…

…it does not appear in the software center as being installed:

Similar issues may be happening with other packages, but this is the only one that I’ve experienced this with so far. It appears that I need samba to be installed for ipsec, so I’ll be reinstalling it. But I thought this behavior was odd and thought I’d share.


(Giacomo Sanchietti) #2

See Strange behavior between software center and YUM

By the ways, without samba l2tp authentication will not work.


(Adam) #3

Why even have the option to uncheck the samba package then?

It’s not very confidence inspiring to tell a server not to install something then it installs anyway. I’d prefer that check-box just didn’t exist.


(Jose "Martin" Abeleira. AKA Marto) #4

Adam which version are you installing?


(Adam) #5

This was on 6.6 with standard repo.


(Davide Principi) #6

L2TP/PPP requires only a samba client to perform authentication against a PDC server. Today only the localhost is allowed as PDC.

We can move towards two directions:

  • Insert L2TP support in a separate package, to avoid installing Samba servers where is not necessary;
  • wait for further development that will allow connecting a remote LDAP/PDC for authentication.

What do you think?

BTW we can fix the module/yum group composition immediately! Edit: see

http://dev.nethserver.org/issues/3276