Using NS6 or NS7 as a Joomla Webserver

Dear community!
We’ve some troubles with setting up a webserver for our Website using Joomla.
What I tried so far: NS6.8 with the wonderful guide ( HowTo install Joomla on NethServer ), worked until I tried to install Joomla 3.6- which unfurtunally needs php 5.3.10, but NS6 only has ver. 5.3.3.
So I tried NS7rc3, which has the right php version, but not webfolders.
Any suggestions? I’d be grateful for help.

PS- I liked the NS6 Toutorial very much, so I would prefer updating the php if possible, off course without braking NS.

You can make use of SCL (Software Collections). @stephdl did a php-scl package for NethServer.

For NS6:

@stephdl, any remarks on its installation/usage?

1 Like

I’ll going to try this. first Need tests : nethserver-php-scl and after this, that HowTo install Joomla on NethServer
thank you for the info. I will provide some feedback :wink:

1 Like

Well for now you cannot install nethserver-php-scl following the link you gave, you need to use my repository, and of course I missed to write down the doku page :slight_smile:

But after that I would know why you don’t want to go with NS7, sure there is no more the shared folder, but you have the virtualhost solution (instead of http://yourIP/joomla, you have If I said that, I’m not so innocent, and I mean that even if the web alias is not the best solution, if you don’t have it in your tools box, it will miss a day :stuck_out_tongue:

I still think that the virtualbox panel could be enhanced by the mod_dav, the user/group authentication, some apache directives, and of course the choice of a web alias or the web virtualhost. it is christmas no ?

@davidep @giacomo what do you think

Concerning nethserver-php-scl for ns6, please let me some few days, probably I want to merge some development done for ns7

And sure, follow the advice of marc, with Centos, if you try to upgrade a version, you will merely break your system, the software collection is always the way to go.


is’nt ist that one?

yum install yum install --enablerepo=remi-phpscl

and I think I prefer the http://yourip/joomla version.

I totally agree.

You could try the new fpm package available in testing:
yum --enablerepo=nethserver-testing install nethserver-rh-php56-php-fpm


You make me jealous :stuck_out_tongue:

Instructions for the giacomo rpm are there

The difference with the rpm of giacomo and mine is that you will need to install all missed rh-php56-php-* rpm

the pro is that you have to write your own web configuration in /etc/opt/rh/rh-php56/php-fpm.d/

1 Like

in fact you can install it by some command line


Don’t be! :smiley: My rpm works only on NS 7 and I’m just searching for some testers! :smiley:


the solution of /etc/opt/rh/rh-php56/php-fpm.d/ is simple and therefore good…the cons, is that you need to know what apache conf to write, but just a copy and paste of any apache configuration is enough

I will do :slight_smile:


I think I’m doing something wrong- installation does not work :joy:

Remember @giacomo’s advice is for NS7

1 Like

sorry I,m realy confused now. It was a long day- so which guide is for NS6 now?
thanks for your patience.

Add EPEL repo:

yum localinstall

Disable it:

eorepo centos-base centos-updates nethserver-base nethserver-updates

That is looking good now. Do I have to reable the other ropo’s afterwards (sorry I’m just a physician :wink: )

no it should be good now, go to the shared folder of joomla and enable the php version you want or go to the php settings panel and allow the php version for the whole server, take a look to the help page if you need.

1 Like

Thank you so much!
worked perfect!
Just have to bring Joomla there…


also done- everything looks working- thanks again very much folks for helping
So it is now a NS 6.8 with Joomla 3.6.5- Installation worked fine, except the configuration.php had to be generated manually. No I’m facing the next problem. Although there are no restrictions at the shared directory at all the Joomla directories are not writable from the CMS. I’m using php 5.6 for this folder.

So I found out what to do:

[root@cbit html]# cd /var/lib/nethserver/ibay
[root@cbit ibay]# chown -R apache:apache “myinternetfolder”/

and that’s it.
unfortunately the build in Web panel function, does not work.

Merry christmas to evrybody I’am off now.