UserPrincipalName filled differently

activedirectory
v7

(Thorsten) #1

NethServer Version: 7.5
Module: Users and Groups

Hi, I set up a nethserver environment a few days ago. Initially the eMail of my users were populated with xxx@ad.mydomain.tld. I found this especially annoying for SoGo. After a clean new installation, this was not a problem anymore. I do not really remember, but I supposed some kind of “order of module installation”. However this was not a problem anymore.

Starting from today I created a new user, the UserPrincipalName in SoGo was again “xxx@ad.mydomain.tld”. I counterchecked this wis ldapAdmin and I found two different population types for my users
Old user users have user@mydomain.tld
new users have user@ad.mydomain.tld

Some things I did / remember:
I also had some trouble on SoGo and Madsonic, so I removed both modules and reinstalled them. The Madsonic problem is solved, I will write a second support request on my SoGo issue. I created / removed a mail domain and / or vitual hosts. I was also changing ActiveSync between Webtop and Sogo. and Today there were some updates

Does any has an Idea on strange behaviour? This is espcially a little annoying as I do need the UserPrincipalName field for some services on my network which does not behave differntly depending on the user.

Thanks and best regards
tebse


(Thorsten) #2

One more detail:

during first installation, User creation ended with an Error Exit code. I did not remember to have that on the second installtion, however this error came back today.


(Markus Neuberger) #3

Sogo gets it’s maildomain from the domainname part of the server name:

config show DomainName

You may edit the ldap fields with phpldapadmin in kamikaze mode.


(Thorsten) #4

Yes, got hat, thank you, but why did behavior change? It worked as expected for some days. Also I do not want that behaviour, is there any option to change without to alter each user individually?


(Thorsten) #5

DomainName=mylastname.world

-> Correctly, so I do not get why it picks up up ad.mylastname.world


(Markus Neuberger) #6

I checked my servers and a fresh install and could not reproduce the issue. I don’t have the ad in the mail address.

Please check your sogo.conf:

[root@testserver ~]# cat /etc/sogo/sogo.conf | grep -i maildomain
    SOGoMailDomain = "domain.local";

(Thorsten) #7

but maybe there is a fundamental missunderstanding on my end:
I set up Nethserver as servername.mydomain.tld
I set up AD with ad.mydomain.tld
Now I expect my users to have the email user_01@mydomain.tld

is this wrong???


(Thorsten) #8

Counterchecked:

Result: SOGoMailDomain = “mylastname.world”;
(as expected)


(Markus Neuberger) #9

If you create a new user, do you see the “ad” next to the username field?

grafik


(Thorsten) #10

Clarified for unknown reason