Upgrade from v7rc2 to v7rc3


I installed Nethserver 7 rc2 and would like to upgrade it to rc3. However, I don’t see how to do it in the server manager.
In the release notes of rc3 it is only written that “to upgrade an rc2 installation to rc3, go to the Software Center page and start the update as usual.”.
However, since I am pretty new to Nethserver, I haven’t done any upgrades before…
Could you explain me how it works?

This is my dashboard…

In the left side menu, under Administration, select Software Center. Then the Updates tab is used to apply all the outstanding updates.



Also keep in mind to be aware of this note after you’ve done the upgrade:

Mentioned in the official RC3 Release Thread:


Thank you for the answers!!! It almost worked…! :wink:
now I have some problems with the network configuration. I tried to solve them but since I haven’t solved them successfully, I am now thinking of installing Rc3 from iso… but thanks anyway! :wink:

1 Like

Hi Aaron,
before installing a new Rc3 server from iso please tell us what are your network problems, perhaps we can help.

1 Like

I have the following setup:
internet - router from my ISP - LAN network including the Nethserver and other PCs.
Now Nethserver 7 rc2 automatically set up its network configuration as follows:
Green network with DHCP IP for my LAN network
red network to the internet via PPPoE

In the server manager only the green network was shown. and a warning that I should change the green network to static to prevent troubles. However whenever I did this change, I wasn’t able to connect to the Nethserver anymore (neither to the server manager nor via ssh).
Since I am planing to use the Nethserver as a webserver and therefore I need stability and security, I read some posts in this forum (and also in the wiki) which described approximately the same setting and told that one should add a DMZ (orange interface) which includes the Nethserver. I tested some configurations loosing the connection to the Nethserver from time to time…
I also tested to set the green interface to red and static and added another green interface and so on…

The automatic configuration with the DHCP green interface was however the only one that worked properly… I shouldn’t have changed it and simply ignore the warning in the server manager…

The upgrade to Rc3 hasn’t completed since at that time I had tested some network configuration in which the internet connection of the Nethserver was very very slow (I guess it was the one with a bounded red interface and some orange ones - but I am not sure about the details anymore…).

after that, I first tried to reset the configuration via the server manager but didn’t succeed. I again lost the connection to the Nethserver…
Then I tried to reset the configuration via commands following the guide on http://docs.nethserver.org/projects/nethserver-devel/en/latest/network.html#reset-network-configuration
but even this didn’t restore the connection from my PC (which is in the same LAN as the Nethserver) to the Nethserver…

For the manual configuration at the end of the guide I used exactly the same two interfaces which Nethserver had configured automatically at the very beginning (one green DHCP for the LAN and one red PPPoE for the internet). And they are also shown correctly when I type db networks show

I don’t know what I did the wrong way… and I have no idea how to restore the connection with my PC or the internet…

hope I have explained my problem understandable…
Do you have any ideas for me??? or should I install Rc3 from iso? and should I then leave the network configuration as Nethserver will hopefully configure it automatically (and ignore the warnings in the server manager)?

1 Like

Hi Aaron,
sorry for late answer and thanks for the googd explanation. I’ve had a network problem too after installing a new nethserver. I think it was not the same like yours but perhaps it can help to find your error.

Here’s the tip that Giacomo gave me:
Try to restart the network and after that look at the logs. My error I found in messages.log.

systemctl restart network

Side note: RC4 solved all my network problems during install.

1 Like

did you try with the last RC4? Let us know if it fixes all your issues.

yes, I installed rc4 and upgraded today to the final version…! :wink: Upgrade worked without any difficulties…!

However, the warning is still shown in the dashboard that I use a green interface with DHCP (see screenShot)…
Should I simply ignore it?

If it is a virtual mashine I woult try to do a snapshot and after that I would give a static IP.
But be careful, look which adresse range your DHCP has, and look for every other static IP in your network, because if you have 2 times the same IP you can’t reach this devices anymore.

Yes and no :wink:

A server should always have a static IP, this is the best practice. But with the latest fix on the network part you shouldn’t have any problem using the DHCP on a green interface.

My advice: keep the green interface with DHCP enabled, and let us know if you encounter any problem.
Together we can improve the product!

1 Like

no it is a separate server… I already set the (internal) IP of the server to static in the settings of my router (easybox 904 xDSL). However, it is a dynamic IP since the ISP doesn’t provide static IPs… (that is why I use ddclient btw.)

yes, I will definitely do so! :wink:
There is already one point which I don’t know whether it is normal or not… When I try to access the website from my internal LAN (the same in which the Nethserver is), it only works via the internal IP address and not via the public one… Is that normal? I am a total newbie in the server business, so please apologize my stupid questions… :wink:

It depends on your network configuration. You probably needs to forward the port 80 from router to internal server.

1 Like

yes, ok…
the port-mapping of my router doesn’t work at all (probably a bug of the easybox)…
This has obviously nothing to do with Nethserver…! :wink:


Did you also try it from an external network with your ddns, perhaps your router don’t let out the traffic, where itself is the destination.

1 Like

yes, from an external network everything works great…! DDNS, public IP etc. :slight_smile:
I have forgotten to write this…

1 Like

Ok, I think it’s how I said, the router can’t route to a destination in the same network over an external ip. I’ve read something about this. Perhaps you can setup a route in your hostfile at the client, or doy you have a dns server in your network?

I’ve found something more, look at this

They explain why the problem/feature exists and how you can fix it in an easy way.

1 Like

Did you resolve? Please mark the the topic as solved.