Updates fail after upgrade to 6.7 with ddclient


#1

I have updated to 6.7 yesterday, I found it too fast but why not. I have tried to use Activesync from WebTop but without success. Today, I have 214 updates available, but could not get through with the following error:
"[YumTestTransactionError] Erreurs de la transaction de test : file /usr/share/nethesis/NethServer/Language/it/NethServer_Module_DdClient.php from install of nethserver-lang-it-1.0.14-1.ns6.noarch conflicts with file from package nethserver-ddclient-1.0.1-3.ns6.noarch"
Any idea to solve that?
Thank you
Loïc


#2

yes, confirmed. i’ve tried to install nethserver-ddclient on a 6.7rc1 before the final release and it worked so i don’t know…

if you don’t need ddclient
$ yum remove nethserver-ddclient
$ yum update
if you need ddclient give me some time to understand what’s changed from rc1…


#3

I need ddclient because my server is at home behind a dynamic dns.
And thank you for your time and work.


(Giacomo Sanchietti) #4

This caused by this issue: http://dev.nethserver.org/issues/3265

The fix is already in place, but the packaged didn’t released a new package.
Also the package has been never published in nethforge-testing repo, and even worst there isn’t a nethforge-testing repository for 6.7.
Sadly the guy who is handling this stuff is not available at the moment, but give few days and I will try to fix it.
I will let you know.

For now, you just have to remove the package, but don’t worry, the configuration remain in place and ddclient should continue to work :smile:


#5

ok, it seems to work now… if you want to test it:

  • if you don’t have dz00te repo configured:
    add the repo:

    cat << ‘EOF’ > /etc/yum.repos.d/dz00te.repo
    [dz00te]
    name=dz00te repository for nethserver $releasever - $basearch
    baseurl=http://mirror.framassa.org/NethServer/$releasever
    enabled=0
    gpgcheck=1
    gpgkey=http://mirror.framassa.org/NethServer/RPM-GPG-KEY-dz00te
    EOF

    $ yum --enablerepo=dz00te update nethserver-ddclient

  • if you already have have dz00te repo configured:

    $ yum clean all --enablerepo=*
    $ yum --enablerepo=dz00te update nethserver-ddclient

then

$ yum update

you should see the new package installed nethserver-ddclient-1.0.1-4.el6.noarch.rpm


#6

[Do I have to unistall ddclient first?]
Update running…


#7

no you should first update nethserver-ddclient and then update to 6.7
but removing nethserver-ddclient > update to 6.7 > reinstall new nethserver-ddclient should also work


#8

Everything seems to have worked allright. Thank you.
After reboot, Jabber does not work, any advice?


#9

sorry i don’t use jabber, but open a new thread to discuss details about it and mark this as solved
tnx