Update not possible! - Nextcloud 11 corrupted file(s)


yum reinstall nethserver-nextcloud

Thank you !
Fixed for me too!

Thank you @dnutan !
Thank you @davidep !

Now it works!

Could you explain why is it necessary?

Is it always required when upgrading 10?

In my case it was a clean install where nethserver-nextcloud was installed yesterday while nextcloud package failed. Maybe a signal-event nethserver-nextcloud-update sufficed.


I saw during unsuccessful updates that the previous version, nextcloud-10.0.2-1.ns7.noarch, must be removed.

Running transaction
  Updating   : nextcloud-11.0.2-1.4.ns7.noarch                                                                                                           1/2
Error unpacking rpm package nextcloud-11.0.2-1.4.ns7.noarch
error: unpacking of archive failed on file /usr/share/nextcloud/core/skeleton/Nextcloud Manual.pdf;58e8d6f6: cpio: read
  Verifying  : nextcloud-11.0.2-1.4.ns7.noarch                                                                                                           1/2
nextcloud-10.0.2-1.ns7.noarch was supposed to be removed but is not!
  Verifying  : nextcloud-10.0.2-1.ns7.noarch

Maybe during this remove, the nethserver-nextcloud also should be removed.
Just said my opinion.

Maybe somebody else will run only signal-event nethserver-nextcloud-update and we will see what happens.

1 Like

i’ve noted too, but now it seems correctly updated
# rpm -qa | grep nextcloud
give me the correct packages installed…

i’ve tried an update from a nc10, clean install, no user and i didn’t had those problems… i’ll make some other tests in the next days…

1 Like