Update Link Error

yum
updates

(Reggie Ho) #1

NethServer Version: 7.4.1708
Module: your_module

Recently I did a yum update … and now it seems the last update has broke some links…
I’m getting message :
One of the configured repositories failed (Unknown),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:
-----end message —
Cannot retrieve metalink for repository: epel/x86_64. Please verify its path and try again

I tried doing " yum clean all " to fix the problem link, not successful. Now It seems I’m not able to do any update … not sure how to fix the problem ? appreciate some suggestion


(Markus Neuberger) #2

Does DNS resolving work?

You may edit the .repo files:

Another thread that may help you:


(Reggie Ho) #3

Thnx…I followed the last instruction…
If I do —> yum clean all --enablerepo=*; yum update --disablerepo=epel

It works and updated… after reboot … if I do – yum update — again problem still exist.

Only works if re-run the
yum clean all --enablerepo=*; yum update --disablerepo=epel

Not Sure what I have to change to fix the epel/x86_64. …


One of the configured repositories failed (Unknown),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=<repoid> ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable <repoid>
    or
        subscription-manager repos --disable=<repoid>

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot retrieve metalink for repository: epel/x86_64. Please verify its path and try again


Also after bootup I still see the issue:


This error message came up since my update last week…


(Reggie Ho) #4

May be I have screwed up using the epel-testing.repo in my Update last week…

Looking at the the yum.repos.d …

here are my files

CentOS-Base.repo
CentOS-Media.repo
CentOS-Vault.repo
NethServer.repo
CentOS-CR.repo
CentOS-SCLo-scl.repo
epel.repo
epel-testing.repo
stephdl.repo
CentOS-Debuginfo.repo
CentOS-SCLo-scl-rh.repo
CentOS-fasttrack.repo
CentOS-Sources.repo
NethForge.repo

I see a copy of epel-testing.repo in the directory… how can I be sure it’s reading the correct epel.repo ?


(Markus Neuberger) #5

epel-testing is not enabled by default, see last line enabled=0:

[root@server ~]# cat /etc/yum.repos.d/epel-testing.repo
[epel-testing]
name=Extra Packages for Enterprise Linux 7 - Testing - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/testing/7/$basearch
metalink=https://mirrors.fedoraproject.org/metalink?repo=testing-epel7&arch=$basearch
failovermethod=priority
enabled=0

(Reggie Ho) #6

Thanks… I checked the epel-testing.repo, it is not enabled…
If I do — > yum-config-manager --disable epel

and then do —> yum update … I don’t get the ERROR Message…
Should I keep the epel.repo disabled ?


(Markus Neuberger) #7

No, because this is not a good long-term solution. We should find out why epel doesn’t work. You may try to edit the .repo file, set baseurl and comment metalink, you may also try to change download.fedoraproject.org with another mirror:

https://admin.fedoraproject.org/mirrormanager/mirrors/EPEL/7/x86_64

baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
#metalink=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch

Can you ping the epel mirror?

You updated to centos 7.5 and are using the new kernel so ndpi module is not working. You may reboot with older kernel and it should work again. For information on the new updates, the problems and solutions see these threads:


You may try:

yum clean all
rm -rf /var/cache/yum

(Reggie Ho) #8

Yes… I was able to ping both download.fedoraproject.org & https://mirrors.fedoraproject.org

As per your instruction, I commented out the metalink and use the baseurl … & ran --> yum update —> it works ok. No error message.

I then re-commented the baseurl and uncommented the metalink again …
then I ran —> yum clean all & sudo rm -rf /var/cache/yum & ran —> yum update again .

Now it seems to work. Although I have no update at this time but no ERROR Message.

Thanks a lot for the help, it seems for now … it’s working. Should I revert the kernel to older to fix the other DPI issure.


(Markus Neuberger) #9

You’re welcome. I am happy that it works!

You may boot an older kernel or update the Nethserver packages to work with the new kernel as described here:


(Reggie Ho) #10

Thanks. Maybe I’d wait a bit to update to 7.5 Testing…a bit busy on other work at the moment.
Appreciate the help…


(Bill ) #11

running 7.5.1804.
I noticed I stopped getting updates recently and a little googling led me here. Modifying the metalink data as suggested above does get yum update to work, however putting it back to original will just cause it to fail again. Yes I cleared the cache. The nethserver admin page shows my updates as “locked” trying to set it to “unlocked” results in the following error:

Cannot retrieve metalink for repository: epel/x86_64. Please verify its path and try again

The install/update may have failed due to metadata caching issues. Please clean the cache by clicking the button below and retry the install/update operation.


(Reggie Ho) #12

Yes… I have the same error too after recently installed the 7.6Beta2. The updates work for 2 days then stopped…maybe the development team @dev_team can enlighten us here. Could be the repository is being updated with the final release being so close…


(Giacomo Sanchietti) #13

We were working on mirrors for the final release. Everything should be fixes within few hours as soon as all mirror are in sync.


(Reggie Ho) #14

Thank you… I just try using GUI Update… that works ! Great to see the new 7.6 Final release… Congratulation…

As of a few moment ago, Command line yum update is not working yet.
I’d check again later…
Thank you all for the release…


(Bill ) #15

Unfortunately I’m still getting the same error. gui update fails, yum update fails.

If I comment out metalink and use base url my gui shows the update to 7.6.
Would there be any harm leaving it like that and doing the update? will update write a new epel.repo hopefully fixing the problem?


(Reggie Ho) #16

Yes…my command line update failed too… For the New Nethserver that I setup using the 7.6Beta., I was able to update using GUI but not from command line…
Another problem I’m having is in the Software Center - the Available and Installed pages are not showing any of the APPs available or installed…


Maybe have to wait for the Nethserver 7.6 ISO release to test it out again…


(Bill ) #17

I took a snapshot of my nethserver VM and tried to update to 7.6. There were a lot of errors and it got stuck in an update loop. I ended up restoring the snapshot. I also noticed an email domain in my allow email settings was marked as spam. Seems like my Nethserver install is committing suicide. I have had a couple unexpected shutdowns on the vm due to a defective UPS over the past 6 months so it’s possible something somewhere is corrupt.
Looks like a fresh install is in my future.


(Bill ) #18

After a little more troubleshooting it looks like changing https to http in the
“metalink=https://mirrors.fedoraproject.org/metalink?repo=testing-epel7&arch=$basearch” line allows yum update to run.
I don’t know much about repos but is it possible a repo either has an expired certificate or worse has been hijacked?

Looks like this is the offending site: https://mirror.us.leaseweb.net/epel/7/x86_64/

Anyways, now running 7.6.1810(final)


(Reggie Ho) #19

I did another test… installing 7.5 and then update to 7.6… seems like it’s all working…