Update failed nethserver-sssd

v7
sogo
updates

(Gerald Brandt) #1

NethServer Version: 7.3.1611
Module: nethserver-sssd

I just tried an upgrade from 7.3.1611 to the latest. I had a brief message on the GUI about an issue with nethserver-ssd which was quickly replaced with a yum clear cache request.

After that, my sogo install would no longer work, with this error:

Dec 27 12:06:24 sogod [1510]: 192.168.103.158 “GET /SOGo/so/gbr/Mail/UIxMailMainFrame HTTP/1.1” 404 208/0 0.005 - - 0

I reverted back to my snapshot, and everything is running again. I’m willing to try another upgrade if someone can tell me where to find more info on the sssd upgrade.

Thanks,
Gerald


(Markus Neuberger) #2

Please provide some more of the logs (upgrade process, restarting sogo) /var/log/messages and /var/log/sogo/sogo.log if possible. In /var/log/messages you should also find the issue replaced by clear cache request if it happens again.


(Gerald Brandt) #3

I will try an upgrade tomorrow.

Gerald


(Gerald Brandt) #4

This looks like the pertinent info in messages

Dec 28 12:02:50 sogo esmith::event[7438]: expanding /etc/systemd/system/dovecot.service.d/limits.conf
Dec 28 12:02:50 sogo esmith::event[7438]: expanding /var/lib/nethserver/sieve-scripts/before.sieve
Dec 28 12:02:50 sogo esmith::event[7438]: Action: /etc/e-smith/events/actions/generic_template_expand SUCCESS [0.63143]
Dec 28 12:02:50 sogo esmith::event[7438]: Action: /etc/e-smith/events/nethserver-mail-server-update/S20nethserver-mail-server-conf SUCCESS [0.020955]
Dec 28 12:02:50 sogo esmith::event[7438]: Action: /etc/e-smith/events/nethserver-mail-server-update/S30nethserver-mail-postmap-update SUCCESS [0.333323]
Dec 28 12:02:51 sogo esmith::event[7438]: kinit: Client 'SOGO$@ERLPHASE.COM' not found in Kerberos database while getting initial credentials
Dec 28 12:02:54 sogo esmith::event[7438]: [ERROR] /usr/libexec/nethserver/smbads: failed to add service primaries to system keytab
Dec 28 12:02:54 sogo esmith::event[7438]: [ERROR] /usr/libexec/nethserver/smbads: failed to initialize keytabs
Dec 28 12:02:54 sogo esmith::event[7438]: Action: /etc/e-smith/events/nethserver-mail-server-update
/S50nethserver-sssd-initkeytabs FAILED: 5 [3.81265]
Dec 28 12:02:54 sogo systemd: Reloading.
Dec 28 12:02:54 sogo esmith::event[7438]: [INFO] service amavisd restart
Dec 28 12:02:54 sogo systemd: Cannot add dependency job for unit clamd@amavisd.service, ignoring: Unit not found.
Dec 28 12:02:54 sogo systemd: Stopping Amavisd-new is an interface between MTA and content checkers....
Dec 28 12:02:54 sogo systemd: Starting Amavisd-new is an interface between MTA and content checkers....
Dec 28 12:02:55 sogo systemd: Started Amavisd-new is an interface between MTA and content checkers..
Dec 28 12:02:55 sogo systemd: Reloading.

On this upgrade, SOGo is running fine. Weirdness.

I’m wondering if it has to do with the XFS filesystem sometimes corrupting on Proxmox snapshot.

Gerald