Unable to restore Nethserver from backup [solved]

sogo
restore
backup

(Bill ) #1

I’m trying to move my Nethserver install to another vmware esxi server running on a different machine by doing a fresh install and restoring from a backup. Everything seams to go smoothly except once I’ve competed restoring the config and the files in /var/lib/nethserver I’m unable to get sogo email working properly. I can launch sogo and log into my account but it is very slow, once in my mail page doesn’t show any folders and the main page just says “No mailbox selected”

Thunderbird wont except my password so am thinking permissions issue.
trying to change any password for a user causes a nethserver error:

Nethgui:

404 - Not foundadmin@domain.com

132214839

NethServer Version: 7.4.1708 (Final)
Module: sogo


(Markus Neuberger) #2

Are the mailboxes in /var/lib/nethserver/vmail/ and are they owned by vmail?

ls -l /var/lib/nethserver/vmail/


(Davide Principi) #3

Did you run the restore-data phase?

http://docs.nethserver.org/en/v7/backup.html


(Bill ) #4

All mailboxes are owned my vmail.

I have restored all data.


(Bill ) #5

Ok, I did a fresh install of 7.4.1708 and tried to load latest config backup and during the process it updates me to 7.5 and nothing works right. so it looks like my only choice will be to take a snapshot of my 7.4 vm and update it to 7.5, let it run a backup and then try again. Or wait till 7.5 is out of beta.


(Bill ) #6

When trying to run restored 7.5 now I see these problems.

Services that don’t automatically start on reboot: Dovecot, mysqld, rh-php56-php-fpm, suricata.

Of those the only one that wont start manually is suricata.

If I then goto users and groups, click on any users edit button and then hit submit is says task completed with errors. If I try to change the password for any user it says 404 not found username.

If I try to login to any sogo user account I get wrong user name or password.

Nextcloud just gives me a blank web page with nothing on it.


(Bill ) #7

Progress! Re-installing configuration from backup and my email is working and I can modify users again, still no Nextcloud but I can probably re-install the app and put data back.

In short: Installed 7.4 from cd, import config of 7.5 backup during setup, reboot, restore all data from backup, reboot, install all updates, reboot, re-import config from backup and reboot.


(Bill ) #8

Spoke too soon. Remotely from my cell phone I can use active sync to connect to my account but I get no data. Using remote browser I can log in to my sogo account and even get a welcome message but then just a blank page. Reinstalled nextcloud and still just get a blank page.


(Bill ) #9

I’m back running on my old server and everything is working again. I really don’t understand why i cant move my existing nethserver install from one machine to another by using the backup and restore feature.


(Davide Principi) #10

We can try to investigate your issue if you attach the full /var/log/messages contents. I suggest to share it with https://gist.github.com/ because it should be really long.


(Bill ) #11

My attempts to restore a running nethserver intall to a new virtual machine have been getting more bizare over the last couple weeks. I have seen more errors than i can count. My last couple attemps would result in being unable to connect to the web interface of a fresh nethserver 7.5.1804 install. I was running Firefox on a Linux mint machine. It would time out while performing a tls handshake and then firefox would crash.

So I fired up my old windows 7 machine with chrome on it and I was able to restore all my config and data and have my new server running in minutes. Seems that nethserver and my Linux mint desktop with Firefox just don’t play well together. Anyways problem solved.


(Markus Neuberger) #12

Sometimes Firefox has problems with the local cert store, renaming the cert db file may help in this case:

An easy way to do this is to browse to about:support and then click the Open Folder button for the Profile Folder. Locate cert9.db in your file explorer and rename the file (e.g. “cert9.db.bak”) so that Firefox replaces it. Restart the browser and try visiting an affected site again. If the page loads normally, you have confirmed the issue is related to the local certificate database storing too many self-signed certificates with the same name.