Unable to migrate from SME

migrate
v7
migration

(Filippo Carletti) #21

I reproduced the error with your information_schema.dump.
Please delete it before attempting a new migration.


(paul_marwick) #22

Sorry to be slow. I did a fresh install, got a fresh backup from the SME server and tried the migration again. After unpacking the archive to /var/lib/migration I copied /root/.my.cnf to /var/lib/migration/root and deleted /var/lib/migration/home/e-smith/db/mysql/information_schema.dump

After that, I ran the migration. It went through without errors. But I can’t report success - at the end of the migration, I set up red and green interfaces. DHCP for the local net worked, but there was no DNS, either local or internet. From a connected machine, I could not ping anything out o the local networkf either by name or IP. Logging in to the server directly, I could not ping anything - attempting to ping the Google DNS servers by IP got me a "network unreachable’ error, which makes me think the system is not acting as a gateway between the local network and the internet at all.

Have I missed something in the setup? I’ve read the firewall section of the docs hoping to find something, but the “network unreachable” error makes me think that the system is not bridging between the local and internet at all. I’d be grateful for suggestions as to what to check…


(paul_marwick) #23

Now I feel pretty silly. I’ve worked out the problem with the DNS and internet access. Should have spotted it earlier. Several things don’t appear to be migrated - existing IPs and server name at least.

What caused the problem here was that I had the green interface on a fixed IP, I had forgotten about the red interface - it was still on DHCP. The router assigned a different IP to the red interface and the gateway information I had set for the green interface was no longer valid. So no communication between red and green at all…

A suggestion - the web interface warns against leaving a green interface on DHCP, but says nothing about a red interface being on DHCP. So it was quite easy to forget to check that one. Might be a good idea to add a warning about the red interface as well.

I’d also like to see a bit more information about what is set during a migration of this sort. Or for that matter, a restore from backup. In the case of the SME - Nethserver migration, I had to install all the needed modules and an account provider before I started the migration. From what I can see, the same would apply when installing a backup to a new server build. Which makes the question about manual configuration or restore from a backup somewhat misleading.

Another question that occurs to me because of this is whether the rsync migration can be used to update a server after a complete migration has been done. Reason I want to know is that for the moment I’m going to have to go right back to a clean install to try and get an up to date migration of the SME server.