Try out NethServer 7 alpha2 ISO!

This time i installed vpn. The installation was successfull. I klicked the button and hat normal softwarecenter again and vpn was correctly installed.

Hi! At first, thanks for great work! I installed the NS7 on my home router/firewall PC, to test it on “not so high load”

  1. I did not succeed to install it no my PC (DELL Precision T3400) from the ISO. When I install on Virtualbox, all was ok, but if I write ISO in USB stick, it stops on message No floppy controller installed. (my floppy controller is disabled in BIOS). I tried few tools to create the USB stick - DD in linux, win32diskimager and Rufus on Win10 - all give the same result. I try to download from different mirrors - same result. Checking the Rufus logs, give following error “libcdio: from_733: broken byte order”.
    But since I can not find the problem in any posts, I suppose it is just me, so I move forward with fresh minimal CentOS 7 and installing NS 7 from packages.

  2. Tried the VPN (openVPN) without success. openvpn@host-to-net service is Stopped, here is the log:
    Apr 17 14:49:53 servelis control-service: openvpn@host-to-net start
    Apr 17 14:49:53 servelis systemd: Starting OpenVPN Robust And Highly Flexible Tunneling Application On host/to/net...
    Apr 17 14:49:53 servelis systemd: openvpn@host-to-net.service: control process exited, code=exited status=1
    Apr 17 14:49:53 servelis systemd: Failed to start OpenVPN Robust And Highly Flexible Tunneling Application On host/to/net.
    Apr 17 14:49:53 servelis systemd: Unit openvpn@host-to-net.service entered failed state.
    Apr 17 14:49:53 servelis systemd: openvpn@host-to-net.service failed.
    I enabled testing repo, updated openVPM, but still no luck.

  3. I have Multi Wan configuration. Both links are active, but in dashboard both are indicated DOWN There is configured ping to google DNS ( and I can succesfully ping the address from terminal.

  4. Just on my wishlist - would be nice, to have more control about IPS rules - possibility to see active, download and activate rules from web interface.

  5. Still testing - Shared folders. (NS 7 as Workstation in Win network) Folder/user defined, but still cannot access the server.

  6. File2ban - I saw the 3rd party module for NS 6, but would be nice to have it also in NS7. I already see some poking on my SSH port (will change as suggested), but IPS is ignoring it.


Now I am testing Owncloud on NS 7.

I set the External Storage to my shared folders and it works fine, but have a few issues:

  1. I can’t access to the private share (Z:)
  2. Cannot send and create any fileson the owncloud interface
  3. Cannot open doc/odt files. Already installed libreoffice-headless.


I can reproduce the bug, but I’ve no idea what is the cause, but I hope your error log will help to track down the issue.

Can you please execute these commands and post the output?

systemctl start openvpn@host-to-net.service
systemctl ststus openvpn@host-to-net.service
journalctl -xe

I will test it.

Modules will be ported by the maintainer only after the beta is out :slight_smile:

I don’t know enough ownCloud, so I even don’t know what you’re referring to. /cc @alefattorini @alep

Please paste logs from owncloud and ssl_error_log.

@marceloeng you should open a new topic I guess, please upload a screenshot of your configuration.

Sorry, I switched my home server to 6.7. I will try to install NS7 to virtualbox and will check, if I can reproduce this.

1 Like

OK @alefattorini

Trying to update my NethServer 7 today I obtain

Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-NethServer-7
The GPG keys listed for the "NethServer 7.2.1511 updates" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.

 Failing package is: nethserver-lang-en-1.0.20-1.ns7.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-NethServer-7

What does it mean?

We changed GPG keys, you should reinstall the have a clean system :wink:

1 Like

Hi do you have an estimated time when NS7 will be released as stable build? BTW I really like the layout of this forum. So different from others and easy to read.

There isn’t any ETA yet, likely late summer. I guess Alpha3 will be available soon, thought.
Community platform is based on feel free to ask about it.

Fail2ban will Probably work out of the box, install it accordingly the wiki page (change the epel repository to epel7)

Testing Nethserver for first time, trying out 7 alpha2. I may have found bugs. Forgive me for not being versed in the stable branch enough to know if these are bugs or I missed something. I can setup a stable server, but currently have my 2 test servers with the prior tech solution and NethServer 7 alpha2 for side by side comparisons, and I have to put another server together first. p.s. basic web filtering has been working well and I am very Happy with the NethServer approach so far! Will continue testing in the next few days…

Collectd Graph Panel will not open, but gives error: Nethgui: 404- Language not found 1277519247
Lightsquid give same error
Ntop works fine

Let me know if I can provide additional info or help with this issue. My use case is central America children’s home. I am looking at replacing a different solution and maybe using for multiple organizations. For me this is part time volunteer work, but my favorite job :smiley:

1 Like

Lot of updates for v7a2 test instance, the devs are really hard at it! Excellent!


Greet to see you heavily focused on testing the new release! I just noticed that you have joined recently, welcome aboard!

I’d like to know more about this project, sounds very cool! Please reply to this topic and introduce it to the whole community.

Devs love such comments! And they love good beer :beer: even more. Please send them a case!

I’ve just installed SOGo3 on Nethserver 7 alpha 2 and getting an “502 Proxy Error” instead of SOGo logon screen.
There is an exception in SOGo log:

Apr 27 22:00:15 sogod [2078]: <0x0x7f9fcb733c90[SOGoCache]> Cache
cleanup interval set every 300.000000 seconds
Apr 27 22:00:15 sogod [2078]: <0x0x7f9fcb733c90[SOGoCache]> Using
host(s) ‘’ as server(s)
EXCEPTION: <NSException: 0x7f9fcbe2a390>
NAME:NSInvalidArgumentException REASON:init with obj and key arrays of
different sizes INFO:(null)
Apr 27 22:00:15 sogod [1333]: <0x0x7f9fcb9c1630[WOWatchDogChild]>
child 2078 exited
Apr 27 22:00:15 sogod [1333]: <0x0x7f9fcb9c1630[WOWatchDogChild]>
(terminated due to signal 6)
Apr 27 22:00:15 sogod [1333]: <0x0x7f9fcba32b80[WOWatchDog]> child
spawned with pid 2099

It should be solved in SOGo 3.0.3 as stated here:
enter link description here

It was a clean install only SOGo and mail modules installed and updated - and not working out of the box for me :cry:

Please, we should follow-up your existing topic: SOGo 3 is released

Alpha2 is going to end!