Testers needed nethserver-arm img

testing
arm

(Mark Verlinde) #101

There is a little bit more to this: Om arm we are missing the restic-0.9.1-1.ns7 package.

Under investigation…:blush:


(Robert Moskowitz) #102

I saw a reference somewhere that there are two domain groups

domain admins
domain users

But only admins is showing. Do I need to create the users group?

I don’t know if the issue is I don’t know or something wrong/missing with the armhfp build.


(Mark Verlinde) #103

Mitigated this for the time being by removing the latest version from the repo

yum clean all && yum makecache

and try to install Backup again


(Robert Moskowitz) #104

Install worked this time. Now to configure.

What there is nothing to configure? Only en/dis able data backup?

Not what is backed up, when, or to where?

I will continue to use rsync and crontab then…


(Mark Verlinde) #105

please read the doc:

http://docs.nethserver.org/en/latest/backup.html
http://docs.nethserver.org/en/latest/backup.html#data-backup-customization

NOTE: for the time being Restic Engine is not available


(Robert Moskowitz) #106

Oh, yea. Look for docs. Don’t assume everything is nicely handled in dialog window… :slight_smile:


(Mark Verlinde) #107

I think you making it to hard for yourself. If you stay within the default configurations offered you do not have to do any thing, it just does the job. i.e if you install a mailserver mails gets backed-up, if you install roundcubemail the database gets backed up, if you make a fileshare data gets backed up… However everything is customizable


(Robert Moskowitz) #108

In my current setup, all data is backed up nightly via a number of rsync crontab jobs to a 2TB USB drive. Don’t have one, yet, for testing on this server.

And saturday night, this is repeated but to a network attached C7-arm server with a 4TB USB drive. The plan is to move this to my neighbor’s for off-site backup…


(Davide Principi) #109

They are quite different. Both are present in AD by default. Apart from that, a user is always member of domain users: the membership is granted implicitly when the account is created. For this reason that “magic” group is not listed.

Domain admins are similar to any “normal” group. Membership must be granted explicitly. Members of that group are granted special domain privileges too.


(Robert Moskowitz) #110

Oh, I know the difference. The point is that ‘domain users’ is not showing up under the groups tab, nor selectable for adding a use. I can, perhaps, see why if all users are always a member of this group.

Just not what I expected.

Moving on.

And still cannot connect to accounts provider from the Status, Domain Accounts.


(Markus Neuberger) #111

Does it work from command line:

account-provider-test dump

Can you list the users?

/usr/libexec/nethserver/list-users


(Robert Moskowitz) #112
{
   "BindDN" : "ldapservice@HOME.HTT-CONSULT.COM",
   "LdapURI" : "ldaps://nsdc-homebase.home.htt-consult.com",
   "DiscoverDcType" : "ldapuri",
   "StartTls" : "",
   "port" : 636,
   "host" : "nsdc-homebase.home.htt-consult.com",
   "isAD" : "1",
   "isLdap" : "",
   "UserDN" : "dc=home,dc=htt-consult,dc=com",
   "GroupDN" : "dc=home,dc=htt-consult,dc=com",
   "BindPassword" : "_XXXXXXXXXXXXXXXXXXX",
   "BaseDN" : "dc=home,dc=htt-consult,dc=com",
   "LdapUriDn" : "ldap:///dc%3Dhome%2Cdc%3Dhtt-consult%2Cdc%3Dcom"
}

I broke this up into a line per user instead of the one long line it produced.

{"administrator@htt-consult.com":{"locked":1,"gecos":"Administrator","expired":0,"groups":[],"shell":"/usr/libexec/openssh/sftp-server","new":0,"expires":"yes"}
,"admin@htt-consult.com":{"locked":1,"gecos":"NethServer Administrator","expired":0,"groups":[],"shell":"/usr/libexec/openssh/sftp-server","new":1,"expires":"yes"}
,"abba@htt-consult.com":{"locked":0,"gecos":"Abba","expired":0,"groups":[],"shell":"/bin/bash","new":0,"expires":"no"}
,"rgm@htt-consult.com":{"locked":0,"gecos":"Robert Moskowitz","expired":0,"groups":[],"shell":"/bin/bash","new":0,"expires":"no"}}

I thought that the users would be created in the AD zone of home.htt-consult.com, not the ‘root’ zone of htt-consult.com

But the web tool still cannot connect to get status.


Setting up a PDC on armhfp
(Mark Verlinde) #113

For some reason the centos PI kernel defaults to power-save scaling governor. On our RPI images a systemd service “cat’s” ondemand in each scaling governor of all 4 cpu’s.

I do not have hardware with (centos) kernel support for CPUFreq, hence /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor is absent.

@rgmhtt is it present on Allwinner A20 SOC’s ?
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

Or are there other means to check the scaling governor and/or current CPU frequency?


(Robert Moskowitz) #114

Blank if I know anything about cpufreq! It freqs me out trying to understand this stuff since the 80286!

Anyway according to

https://linux-sunxi.org/Mainlining_Effort

A20 has had CPUfreq since kernel 4.0


(Mark Verlinde) #115

the 286 is a failure and intel even admits this: around minute 13 Microprocessor Marketing Wars

Is /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor present or not?


(Robert Moskowitz) #116

Yes, quite the failure…

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

ondemand


(Mark Verlinde) #117

Thanx, there seems no need to correct it non PI devices!


(Mark Verlinde) #118

The images for the Raspberry PI and (other) u-boot based SBC’s are updated to reflect changes in partitioning and swap as discussed here.

Nethserver-7.5.1804-Devel-RaspberryPi-img.raw.xz
Nethserver-7.5.1804-Devel-Generic-img.raw.xz

Changes:

  1. Partitioning (1) Boot (768MB) and (2) RootFS (2560MB), file system for Boot on RPI is FAT32 and Generic ext4.
  2. Small change under the hood: first partition begins @4096 to give more room for (extra) early-stage bootloaders. (unfortunately this is hard-coded in the appliance-tools, hence all images have this change)
  3. Swap is provided by Comressed RAM (zram-swap).
  4. Package file was missing needed by nethserver-duc, it’s included in the nethserver-arm comps group now. (odd thing was functionality does not seem to affected by this bug)
  5. uboot-images-armv7 is installed on Generic image. This way u-boot for your board can be picked up from the just flashed sd-card making it possible to prepare the card on non Centos/Fedora systems.

One odd issue I can’t explain is the size of the compressed images RPI ~ 280MB vs 480MB for Generic. Cause is xz has an lower compression rate for the latter despite the same settings/command…

Short write up to prepare/ flash-uboot for the Generic image:

export sdcard="/dev/sdX"

As always: Be sure you got the right device (/dev/…) pointing to your sd-card

xzcat Nethserver-7.5.1804-Devel-Generic-img.raw.xz | sudo dd of=${sdcard} status=progress bs=4M && sudo sync

Mount your sd-card, mountpoint (/mnt) is arbitrary:
sudo mount ${sdcard}2 /mnt

Find the available boardmodels:
ls /mnt/usr/share/uboot/

(in this writeup orangepi_plus2e is assumed)
export boardmodel="orangepi_plus2e"

Find name of u-boot file:
ls /mnt/usr/share/uboot/${boardmodel}

(turns-out out for orangepi_plus2e it is u-boot-sunxi-with-spl.bin)
export uboot="u-boot-sunxi-with-spl.bin"

Flash u-boot to sd-card:

sudo dd if=/mnt/usr/share/uboot/${boardmodel}/${uboot} of=${sdcard} bs=1024 seek=8 conv=fsync,notrunc

Un mount sd-card:
sudo umount /mnt


(Giacomo Sanchietti) #119

I tried the Devel image using an emulated ARM machine with QEMU, I followed this Fedora documentation

I found a couple of issues:

  • at boot the, the process blocks because the system can’t mount the /boot partition because it doesn’t recognize the vfat filesystem. To fix the problem: enter the dracut rescue console and comment the boot partition inside the fstab. I didn’t spent much time on this, but I couldn’t find a way to mount the vfat partition. Even if the kernel should have the support (grep vfat /usr/lib/modules/4.14.52-v7.1.el7/modules.builtin).
  • firewalld and NetworkManager were running, I had to disable both using systemctl
  • swap is on a partition and no zram block device has been created

Probably next week I will give it another try.

Thank you for work!!


(Mark Verlinde) #120

This is very strange :thinking: i will check the links to the images because the generic image should not have any fat partition. None of the Nethserver images have firewalld enabled and Network Manager is not installed at all.

Strange…

EDIT: (links) to Nethserver images are good…

Very interesting experiment, which could lead to builds on travis cli. :+1: