Testers needed nethserver-arm img

We don’t :slight_smile: But we can manage the release of NethServer 7.6 :wink:

I built a HD with:


Went through firstboot fine, I am logged in as root on the serial console on my Cubietruck. My IP address is

From my F29 arm system on, I try to connect to:

And that does not work; I figured that I needed https. Wow is that default cert weird. I wonder if we can do better. If nothing else we need to move to ECDSA!

Set root’s password? What if I had already done this from the serial console, would I have to change it again?

I DO NOT APPRECIATE YOUR PASSWORD REQUIREMENTS. Fedora Initial Setup is very happy with my password of choice, giving it a good rating. And you don’t even give the password rules. Humph.

Set timezone? Why is not Detroit in the list here? It is in the tz file…

And I am in to the config…

I have two projects: Replace my ClearOS and my RSEL mailserver.

My Cubietruck should be up to replacing ClearOS for my 3 client systems. I will tackle that first as I decide which system to get for the mailserver replacement.

Get me what I need to convert to zram, and I will test switching to that as well…

Meanwhile I am going to figure out what I need to install to get the gnome DE and set up vncserver.

No, only if it is the default (Nethesis,1234)

Rules are quite strict, meanwhile i’m used to it…

Sorry, I do not know. have to look in to this.

A gross description:

  • yum install zram
  • disable swap (swapoff -a)
  • edit /etc/fstab and comment out the “swap line”
  • systemctl start zram-swap
  • systemctl enable zram-swap

Thank you for testing and feedback!

I won’t get into password strict fights. I will see what I can do so it works for me…

timedatectl set-timezone America/Detroit

From the console works. Guess I just missed it in way your list works…

Other than it is ‘swapoff -a’, I am up now with zram. I will work out a sed command to comment out the swap line.

/dev/zram0 lz4         959.4M   4K   64B    4K       2 <swap>

Nice that you already have zram in your repo! Send your rpm directly to Pablo so he can try it out.

1 Like

Actually not hard:

sed -i -e "/swap/s/^/# /w /dev/stdout" /etc/fstab

With all this, you can wrap it up in a script and make it generally available as a Nethserver feature…


setting-up-a-pdc over in Support…

Do you have nethserver-dc available for the generic image?

Hi there!
seems to work for testing purpose for me.

Not sure to use it for production though… :slight_smile:
I could use it for minor light non-critical tasks.
Anyone does?


Thanks for testing!

I used a raspberry as fallback mirror webserver when the main webserver was down for maintenance. It’s enough to run a low perfomance home server.
I can also imagine using it as monitoring agent (with zabbix or nagios).

With better arm hardware than a raspberry there are no limits.


I would definitly do that with a 4Go Ram Pi :smiley:
I have several Raspbian Lite LAMP devices. I’m a bit oldschool when it comes to web servers. No virtual machines, no graphic interface, SSH only and no other service on the machine.
On day I’ll try with NS. But not on a small bug. Maybe on a supercharged Banana Pi?


I have had a Cubietruck running Redsleeve6 as my mailserver for 4 years. It processes ~5k messages per day and supports my very active access with 4 copies of Thunderbird via IMAP and one friend with POP.

The key here is that Cubies have native sata. The CT is 2GB memory duo core. It does get bogged down at times with the anti-virus scanning.

One of my goals is to replace this with a Nethserver mail server. I will probably also move to a quad core to better handle anti-virus scanning. Like the BananaPi M4 Ultra.

Warning if you want to run a desktop on Allwinner boards like Cubies and Bananas: they have the Mali GPU which is closed. None of the upstream kernels have support, so with GTK3, you end up in emulation mode. Fedora28-Xfce (GTK2) was decent on my Cubies. Fedora29-Xfce (GTK3) is bad. They are fine for servers, or if you use vncserver connection from your notebook (as I am doing). The Centos7-gnome works OK (probably GTK2).

I really like these small bugs!

1 Like

A test I did this evening before starting over to get AD started right…

yum groupinstall “gnome desktop”
yum install vncserver

add user
ssh in as user and run vncpasswd
configure vncserver for user
set firewall rule for ports 5901:5903
start vncserver
connect via vnc client

I am in! Also works for user root. Gives me a desktop to do more if I want. Logged out and stopped vncserver.

I would be nice if centos-arm had the Xfce desktop, but not all the modules are there for armhfp. :frowning:

So that is enough for tonight. Shutdown and start over and this time get AD right…

Or righter. Ready, fire, aim, aim, aim…


Planned for merge in kernel 4.20

I just got a failure installing the Backup package. Previously, I had installed AD, File Server, and Basic Firewall.

the red error message says:

Resolving RPM dependencies

The install/update may have failed due to metadata caching issues. Please clean the cache by clicking the button below and retry the install/update operation.

and there is a button to Clear Yum Cache

which I will do…

I have installed AD domain controller. Under Status I clicked on Domain Accounts and got:

Could not connect to accounts provider!

What do I have to do to get this working?

Probably a connection problem (DNS not resolving)

Try restarting the system or look at journalctl, or at systemctl -l status sssd nsdc

1 Like

Or just try again, I had similar behavior yesterday, tried again and since then it’s working and now I can’t reproduce anymore.

There is a little bit more to this: Om arm we are missing the restic-0.9.1-1.ns7 package.

Under investigation…:blush:

I saw a reference somewhere that there are two domain groups

domain admins
domain users

But only admins is showing. Do I need to create the users group?

I don’t know if the issue is I don’t know or something wrong/missing with the armhfp build.

Mitigated this for the time being by removing the latest version from the repo

yum clean all && yum makecache

and try to install Backup again

Install worked this time. Now to configure.

What there is nothing to configure? Only en/dis able data backup?

Not what is backed up, when, or to where?

I will continue to use rsync and crontab then…