Teamspeak looses connectivity after x hours to wan

NethServer Version: 7.2.1511
My setup is as follows:
ISP - pfSense - app server
all ports are routed properly trough my pfSense boks.

I figured I would start a new topic for this issue.
I have installed teamspeak on my nethserver.
The problem is not with teamspeak itself it runs just fine.

But after x amount of hours I can’t connect to the server remotely anymore.
Can still connect trough LAN with out any problems.

If I reboot my nethserver everything works fine for another x hours.
Then I loose connectivity again outside my lan.

Is there anything the in nethserver that needs to be done to prevent this?
I can just assume it gets blocked or something and that the block clears out after a reboot.

I run the exact same server on another debian install, and don’t have any problems there.
So must be something in the nethserver that blocks this.

I need to get this sort of things to work before I can retire my debian app server.

Let me know if you need any additional information.

its setup to use UDP port 9987 which is Teamspeak Voice channel.

If the software (Teamspeak in this scenario), needs some open ports, you need to create specific rules inside the firewall page.
I read a couple of guides for Teamspeak, and it seems to to me that the daemon needs multiple open ports:

You can configure if manually with this command:

config set fw_teamspeak service access public status enabled UDPPorts 9987 TCPPorts 1011,30033

The system will take care to keep open the selected ports.

I will give this another try.
I see the port you have here is wrong. the TS query port will be 10011
I already typed your command.

Do you have the command for changing or removing 1011 from fw? :smiley:
Nevermind found that :slight_smile:

1 Like

Okay, now I’m a little embarrassed.
The main issue here was that I had two instances of teamspeak running (on different servers)
But with same virtual id.

So by closing down the old one entirely, the issue resolved it self.
Thanks for the help,

config set fw_teamspeak service access public status enabled UDPPorts 9987 TCPPorts 10011,30033

helped with one of the issues I had though.


Thanks for taking us in touch :slight_smile: please mark the topic as solved

1 Like