Strong(er) authentication required

Hi guys,
Today I was setting up the firewall server with nethserver to synchronize users using LDAP mode but I get a message Strong (er) authentication required
I’m using AD, Samba 4.6.11

You probably need to connect using LDAPS://… or use port 636

It is unclear to me where the AD accounts reside, or how you are trying to connect to that. Usually, this error is a result of trying to access Samba AD without LDAPS, where it requires TLS1.2 by default iirc.

1 Like

I’ve already tried using port 636 but the same error


I suspect you need to check the SSL checkbox as well. The rest of the settings look ok to me.

I’ve tried this option too but I get this No SSL support! and the same error if I synchronize Strong (er) authentication required

I must admit, I haven’t tried this yet, but have you created an SSL certificate for the server in question? Or are you using the default SSL certificate that comes with the Nethserver installation?

I am using nethserver’s own certificate

Just to be sure, “IP servidor” has to be the IP of your NSDC container, not your Nethserver.
Another idea: Try to use port 389 with SSL enabled.

May I ask which firewall you are trying to join to NethServer AD?

Maybe try create your own custom SSL Cert for the domain on that NethServer installation and see if that will make a difference?

IP of NethServer =
IP of LDAP =

I’ve tried using SSL with port 389
The firewall is from a company called SETI S4, right here in Brazil. I already contacted them and it was they who told me about this mistake

Is this a Java interface? If so, you require a non-self-signed certificate. Follow my recent installation guide on AD and pay attention to the letsencrypt part.

Also, if it is a Java interface … eek!


I did the same procedures as in your tutorial.
But we got it to authenticate using NTLM, It was the way we found it.