Strange update... How to investigate?


#1

Hi,

Today, I was looking my server health, I not do this very often, I’ve got no problem so I forget it :grin:
But, today, there was an update available and I was surprised with what was update:

Jan 09 14:31:39 Updated: samba-winbind-3.6.23-24.el6_7.x86_64
Jan 09 14:31:41 Updated: samba-winbind-clients-3.6.23-24.el6_7.x86_64
Jan 09 14:31:45 Updated: samba-common-3.6.23-24.el6_7.x86_64
Jan 09 14:31:45 Updated: nss-sysinit-3.19.1-8.el6_7.x86_64
Jan 09 14:31:47 Updated: nss-3.19.1-8.el6_7.x86_64
Jan 09 14:31:48 Updated: openssl-1.0.1e-42.el6_7.2.x86_64
Jan 09 14:31:52 Updated: openssl-devel-1.0.1e-42.el6_7.2.x86_64
Jan 09 14:31:53 Updated: nss-tools-3.19.1-8.el6_7.x86_64
Jan 09 14:31:54 Updated: gnutls-2.8.5-19.el6_7.x86_64
Jan 09 14:31:54 Updated: rpcbind-0.2.0-11.el6_7.x86_64

Why there’s a samba update when I don’t use Samba… Below you can see what is installed

How to investigate this case?


(Gabriel GHEORGHIU) #2

Hi Jim,

All those updates are from Red Hat/CentOS, not from NS.

Just one example for “samba-winbind-3.6.23-24.el6_7.x86_64”: https://rhn.redhat.com/errata/RHSA-2016-0011.html

BR,
Gabriel


(Filippo Carletti) #3

AFAIK, samba is required by the L2TP VPN.


(Gabriel GHEORGHIU) #4

Hi Filippo,

VPN is not installed.

I think Samba is using by Web Server (Apache Web Server).

BR,
Gabriel


(Alessio Fattorini) #5

This is my bet: Web proxy requests it for authentication with AD?


(Gabriel GHEORGHIU) #6

There are some log files regarding samba.

EDIT
https://www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-samba-daemons.html

BR,
Gabriel


#7

I don’t have samba log…
I don’t use AD for authentication…


(Gabriel GHEORGHIU) #8

If I remember well, you have installed first CentOS (from USB bootable stick) and then NethServer.
I think Samba was installed with CentOS.
This may be the reason that you don’t have some Samba services from NS (Samba was already installed).

The updates are from / for CentOS and NethServer.
Anyway, like I said, all those updates are from Red Hat/CentOS, not from NS.

BR,
Gabriel


(Artem Fedai) #9

Check pls yum-cron ?


(Davide Principi) #10

@nas is right, yum may have the answer.

yum history pkg-info samba

(Gabriel GHEORGHIU) #11

Like I said from the beginning: all those updates are from Red Hat/CentOS, not from NS.
You can do “yum history pkg-info …” for all “strange updates” and you will get the same answer.


(Davide Principi) #12

Good, it has been installed as dependency on transaction 4

yum history info 4

should provide the details of what has been installed.


(Gabriel GHEORGHIU) #13

Hi Davide,

Here are the details.

I think Jim should make all these tests because for him is a question mark from where are all those updates, not for me. :wink:

[root@ns-utm ~]# yum history info 4
Loaded plugins: changelog, fastestmirror, nethserver_events, presto
Transaction ID : 4
Begin time : Thu Dec 31 10:47:55 2015
Begin rpmdb : 343:446d8d12af8e1956eb806a7f4c22c8f3293f0522
End time : 10:51:45 2015 (230 seconds)
End rpmdb : 466:c8661009724fb11e7c65b15d3fb886e4cf112375
User : System
Return-Code : Success
Transaction performed with:
Installed rpm-4.8.0-47.el6.x86_64 @anaconda-CentOS-201508042137.x86_64/6.7
Installed yum-3.2.29-69.el6.centos.noarch @anaconda-CentOS-201508042137.x86_64/6.7
Installed yum-plugin-fastestmirror-1.1.30-30.el6.noarch @anaconda-CentOS-201508042137.x86_64/6.7
Installed yum-presto-0.6.2-1.el6.noarch @extras
Packages Altered:
Dep-Install GeoIP-1.6.5-1.el6.x86_64 @nethserver-base
Dep-Install GeoIP-GeoLite-data-2015.04-2.el6.noarch @nethserver-base
Dep-Install GeoIP-GeoLite-data-extra-2015.04-2.el6.noarch @nethserver-base
Dep-Install avahi-libs-0.6.25-15.el6.x86_64 @centos-base
Dep-Install c-icap-0.2.5-1.ns6.x86_64 @nethserver-base
Dep-Install c-icap-libs-0.2.5-1.ns6.x86_64 @nethserver-base
Dep-Install clamav-0.98.7-1.el6.x86_64 @nethserver-base
Dep-Install clamav-db-0.98.7-1.el6.x86_64 @nethserver-base
Dep-Install clamav-unofficial-sigs-3.7.1-7.el6.noarch @nethserver-base
Dep-Install clamd-0.98.7-1.el6.x86_64 @nethserver-base
Dep-Install collectd-4.10.9-1.el6.x86_64 @nethserver-base
Dep-Install collectd-ping-4.10.9-1.el6.x86_64 @nethserver-base
Dep-Install collectd-rrdtool-4.10.9-1.el6.x86_64 @nethserver-base
Dep-Install cups-libs-1:1.4.2-72.el6.x86_64 @centos-base
Dep-Install cyrus-sasl-gssapi-2.1.23-15.el6_6.2.x86_64 @centos-base
Dep-Install daq-2.0.2-1.x86_64 @nethserver-base
Dep-Install dejavu-fonts-common-2.33-1.el6.noarch @centos-base
Dep-Install dejavu-lgc-sans-mono-fonts-2.33-1.el6.noarch @centos-base
Dep-Install dejavu-sans-mono-fonts-2.33-1.el6.noarch @centos-base
Dep-Install dnsmasq-2.48-14.el6.x86_64 @centos-base
Dep-Install fontpackages-filesystem-1.41-1.1.el6.noarch @centos-base
Dep-Install gd-2.0.35-11.el6.x86_64 @centos-base
Dep-Install geoipupdate-2.2.1-2.el6.x86_64 @nethserver-base
Dep-Install gnutls-2.8.5-18.el6.x86_64 @centos-base
Dep-Install hiredis-0.10.1-3.el6.x86_64 @nethserver-base
Dep-Install krb5-workstation-1.10.3-42.el6.x86_64 @centos-base
Dep-Install ksh-20120801-28.el6_7.3.x86_64 @centos-updates
Dep-Install libXpm-3.5.10-2.el6.x86_64 @centos-base
Dep-Install libdnet-1.12-6.el6.x86_64 @nethserver-base
Dep-Install libjpeg-turbo-1.2.1-3.el6_5.x86_64 @centos-base
Dep-Install libnetfilter_queue-1.0.2-1.el6.x86_64 @nethserver-base
Dep-Install libnfnetlink-1.0.1-1.el6.x86_64 @nethserver-base
Dep-Install liboping-1.5.1-1.el6.x86_64 @nethserver-base
Dep-Install libtalloc-2.0.7-2.el6.x86_64 @centos-base
Dep-Install libtdb-1.2.10-1.el6.x86_64 @centos-base
Dep-Install libtevent-0.9.18-3.el6.x86_64 @centos-base
Dep-Install libtiff-3.9.4-10.el6_5.x86_64 @centos-base
Dep-Install libtool-ltdl-2.2.6-15.5.el6.x86_64 @centos-base
Dep-Install lightsquid-1.8-11.el6.noarch @nethserver-base
Dep-Install lightsquid-apache-1.8-11.el6.noarch @nethserver-base
Dep-Install lzo-2.03-3.1.el6_5.1.x86_64 @centos-base
Dep-Install nethserver-antivirus-1.1.4-1.ns6.noarch @nethserver-base
Dep-Install nethserver-c-icap-1.0.2-1.ns6.noarch @nethserver-base
Install nethserver-cgp-1.0.0-1.ns6.noarch @nethserver-base
Install nethserver-collectd-1.2.0-1.ns6.noarch @nethserver-base
Install nethserver-collectd-web-1.0.2-1.ns6.noarch @nethserver-base
Dep-Install nethserver-directory-2.3.0-1.ns6.noarch @nethserver-base
Install nethserver-dnsmasq-1.5.5-1.ns6.noarch @nethserver-updates
Install nethserver-firewall-base-ui-2.10.1-1.ns6.noarch @nethserver-updates
Install nethserver-httpd-2.5.1-1.ns6.noarch @nethserver-base
Install nethserver-ipsec-1.1.4-1.ns6.noarch @nethserver-updates
Install nethserver-lightsquid-1.0.3-1.ns6.noarch @nethserver-base
Install nethserver-ntopng-1.3.1-1.ns6.noarch @nethserver-updates
Install nethserver-openvpn-1.3.0-1.ns6.noarch @nethserver-updates
Dep-Install nethserver-pulledpork-1.0.2-1.ns6.noarch @nethserver-updates
Dep-Install nethserver-samba-1.5.4-1.ns6.noarch @nethserver-updates
Install nethserver-snort-1.0.3-1.ns6.noarch @nethserver-base
Install nethserver-squid-1.3.11-1.ns6.noarch @nethserver-updates
Install nethserver-squidclamav-1.1.1-1.ns6.noarch @nethserver-base
Install nethserver-squidguard-1.4.1-1.ns6.noarch @nethserver-updates
Dep-Install nethserver-vpn-1.1.7-1.ns6.noarch @nethserver-base
Dep-Install nscd-2.12-1.166.el6_7.3.x86_64 @centos-updates
Dep-Install nss-pam-ldapd-0.7.5-20.el6_6.3.x86_64 @centos-base
Dep-Install ntopng-2.0.150531-164.x86_64 @nethserver-base
Dep-Install ntopng-data-2.0.150531-164.noarch @nethserver-base
Dep-Install numactl-2.0.9-2.el6.x86_64 @centos-base
Dep-Install openldap-clients-2.4.40-7.el6_7.x86_64 @centos-updates
Dep-Install openldap-servers-2.4.40-7.el6_7.x86_64 @centos-updates
Dep-Install openpgm-5.1.118-3.el6.x86_64 @nethserver-base
Dep-Install openswan-2.6.32-37.el6.x86_64 @centos-base
Dep-Install openvpn-2.3.7-1.el6.x86_64 @nethserver-base
Dep-Install pam_ldap-185-11.el6.x86_64 @centos-base
Dep-Install perl-Archive-Tar-1.58-141.el6_7.1.x86_64 @centos-updates
Dep-Install perl-Authen-Krb5-1.9-1.el6.x86_64 @nethserver-base
Dep-Install perl-Authen-SASL-2.13-3.el6.noarch @centos-base
Dep-Install perl-CGI-3.51-141.el6_7.1.x86_64 @centos-updates
Dep-Install perl-Config-General-2.52-1.el6.noarch @centos-base
Dep-Install perl-Convert-ASN1-0.22-1.el6.rfx.noarch @nethserver-base
Dep-Install perl-Convert-BinHex-1.119-10.1.el6.noarch @centos-base
Dep-Install perl-Crypt-SSLeay-0.57-17.el6.x86_64 @centos-base
Dep-Install perl-DBI-1.609-4.el6.x86_64 @centos-base
Dep-Install perl-Digest-HMAC-1.01-22.el6.noarch @centos-base
Dep-Install perl-Digest-SHA1-2.12-2.el6.x86_64 @centos-base
Dep-Install perl-GD-2.44-3.el6.x86_64 @centos-base
Dep-Install perl-GDGraph-1:1.44-7.el6.noarch @centos-base
Dep-Install perl-GDGraph3d-0.63-12.el6.noarch @centos-base
Dep-Install perl-GDTextUtil-0.86-15.el6.noarch @centos-base
Dep-Install perl-GSSAPI-0.26-6.el6.x86_64 @centos-base
Dep-Install perl-IO-Socket-SSL-1.44-1.el6.rfx.noarch @nethserver-base
Dep-Install perl-IO-Zlib-1:1.09-141.el6_7.1.x86_64 @centos-updates
Dep-Install perl-IO-stringy-2.110-10.1.el6.noarch @centos-base
Dep-Install perl-LDAP-1:0.40-2.nh.noarch @nethserver-base
Dep-Install perl-MIME-tools-5.427-4.el6.noarch @centos-base
Dep-Install perl-MailTools-2.04-4.el6.noarch @centos-base
Dep-Install perl-Net-SSLeay-1.36-1.el6.rfx.x86_64 @nethserver-base
Dep-Install perl-Package-Constants-1:0.02-141.el6_7.1.x86_64 @centos-updates
Dep-Install perl-RRD-Simple-1.44-1.el6.rf.noarch @nethserver-base
Dep-Install perl-Text-Iconv-1.7-6.el6.x86_64 @centos-base
Dep-Install perl-XML-Filter-BufferText-1.01-8.el6.noarch @centos-base
Dep-Install perl-XML-LibXML-1:1.70-5.el6.x86_64 @centos-base
Dep-Install perl-XML-NamespaceSupport-1.11-1.el6.rfx.noarch @nethserver-base
Dep-Install perl-XML-SAX-0.96-7.el6.noarch @centos-base
Dep-Install perl-XML-SAX-Writer-0.50-8.el6.noarch @centos-base
Dep-Install pkcs11-helper-1.11-3.el6.x86_64 @nethserver-base
Dep-Install portreserve-0.0.4-9.el6.x86_64 @centos-base
Dep-Install pulledpork-0.7.0-2.noarch @nethserver-base
Dep-Install redis-2.4.10-1.el6.x86_64 @nethserver-base
Dep-Install rrdtool-1.3.8-7.el6.x86_64 @centos-base
Dep-Install rrdtool-perl-1.3.8-7.el6.x86_64 @centos-base
Dep-Install samba-3.6.23-21.el6_7.x86_64 @centos-updates
Dep-Install samba-client-3.6.23-21.el6_7.x86_64 @centos-updates
Dep-Install samba-common-3.6.23-21.el6_7.x86_64 @centos-updates
Dep-Install samba-winbind-3.6.23-21.el6_7.x86_64 @centos-updates
Dep-Install samba-winbind-clients-3.6.23-21.el6_7.x86_64 @centos-updates
Dep-Install snort-1:2.9.7.2-2.x86_64 @nethserver-base
Dep-Install snortalog-0.0.1-1.ns6.noarch @nethserver-base
Dep-Install squid-7:3.3.13-1.el6.x86_64 @nethserver-base
Dep-Install squidGuard-1.4-9.el6.x86_64 @nethserver-base
Dep-Install squidclamav-6.10-1.ns6.x86_64 @nethserver-base
Dep-Install tdb-tools-1.2.10-1.el6.x86_64 @centos-base
Dep-Install xl2tpd-1.3.6-1.el6.x86_64 @nethserver-base
Dep-Install yajl-1.0.7-3.el6.x86_64 @centos-base
Dep-Install zeromq3-3.2.5-1.el6.x86_64 @nethserver-base
Scriptlet output:
1 /etc/squid/squidGuard.conf created as /etc/squid/squidGuard.conf.rpmnew
2 Setting up redis auto startup
3 Creating link under /usr/local/bin
history info
[root@ns-utm ~]#


(Davide Principi) #14

@Jim, please let us know if those yum commands give an answer :wink:


#15

Exact, but it was a Minimal CentOS

[root@microserver ~]# yum history pkg-info samba
Loaded plugins: changelog, fastestmirror, nethserver_events, presto
Bad transaction IDs, or package(s), given
Error: Failed history packages-info   

:cold_sweat:

[root@microserver ~]# yum history info 4
Loaded plugins: changelog, fastestmirror, nethserver_events, presto
Transaction ID : 4
Begin time     : Mon Sep 14 14:46:28 2015
Begin rpmdb    : 359:6590f15d57a1f00ce2ba20ff35addeb6e772f86f
End time       :            14:48:54 2015 (146 seconds)
End rpmdb      : 443:e3a52292d0a18f8390dc099d30fae09929b136e0
User           : System <unset>
Return-Code    : Success
Transaction performed with:
    Updated       rpm-4.8.0-37.el6.x86_64                       @anaconda-CentOS-201410241409.x86_64/6.6
    Updated       yum-3.2.29-60.el6.centos.noarch               @anaconda-CentOS-201410241409.x86_64/6.6
    Installed     yum-plugin-fastestmirror-1.1.30-30.el6.noarch @anaconda-CentOS-201410241409.x86_64/6.6
    Installed     yum-presto-0.6.2-1.el6.noarch                 @centos-base
Packages Altered:
    Dep-Install GeoIP-1.6.5-1.el6.x86_64                      @nethserver-updates
    Dep-Install GeoIP-GeoLite-data-2015.04-2.el6.noarch       @nethserver-updates
    Dep-Install GeoIP-GeoLite-data-extra-2015.04-2.el6.noarch @nethserver-updates
    Dep-Install bc-1.06.95-1.el6.x86_64                       @centos-base
    Dep-Install c-icap-0.2.5-1.ns6.x86_64                     @nethserver-base
    Dep-Install c-icap-libs-0.2.5-1.ns6.x86_64                @nethserver-base
    Dep-Install cifs-utils-4.8.1-19.el6.x86_64                @centos-base
    Dep-Install clamav-0.98.7-1.el6.x86_64                    @nethserver-updates
    Dep-Install clamav-db-0.98.7-1.el6.x86_64                 @nethserver-updates
    Dep-Install clamav-unofficial-sigs-3.7.1-7.el6.noarch     @nethserver-base
    Dep-Install clamd-0.98.7-1.el6.x86_64                     @nethserver-updates
    Dep-Install collectd-4.10.9-1.el6.x86_64                  @nethserver-base
    Dep-Install collectd-ping-4.10.9-1.el6.x86_64             @nethserver-base
    Dep-Install collectd-rrdtool-4.10.9-1.el6.x86_64          @nethserver-base
    Dep-Install dejavu-fonts-common-2.30-2.el6.noarch         @centos-base
    Dep-Install dejavu-lgc-sans-mono-fonts-2.30-2.el6.noarch  @centos-base
    Dep-Install dejavu-sans-mono-fonts-2.30-2.el6.noarch      @centos-base
    Dep-Install dnsmasq-2.48-14.el6.x86_64                    @centos-base
    Dep-Install duplicity-0.6.22-4.el6.x86_64                 @nethserver-updates
    Dep-Install fontpackages-filesystem-1.41-1.1.el6.noarch   @centos-base
    Dep-Install geoipupdate-2.2.1-2.el6.x86_64                @nethserver-updates
    Dep-Install hiredis-0.10.1-3.el6.x86_64                   @nethserver-updates
    Dep-Install ipset-6.11-3.el6.x86_64                       @centos-base
    Dep-Install keyutils-1.4-5.el6.x86_64                     @centos-base
    Dep-Install ksh-20120801-21.el6_6.3.x86_64                @centos-updates
    Dep-Install libevent-1.4.13-4.el6.x86_64                  @centos-base
    Dep-Install libgssglue-0.1-11.el6.x86_64                  @centos-base
    Dep-Install libmnl-1.0.2-3.el6.x86_64                     @centos-base
    Dep-Install liboping-1.5.1-1.el6.x86_64                   @nethserver-base
    Dep-Install librsync-1.0.0-1.el6.x86_64                   @nethserver-updates
    Dep-Install libtalloc-2.0.7-2.el6.x86_64                  @centos-base
    Dep-Install libtdb-1.2.10-1.el6.x86_64                    @centos-base
    Dep-Install libtevent-0.9.18-3.el6.x86_64                 @centos-base
    Dep-Install libtirpc-0.2.1-10.el6.x86_64                  @centos-base
    Dep-Install lsm-0.179-1.ns6.x86_64                        @nethserver-updates
    Dep-Install ncftp-2:3.2.4-1.el6.x86_64                    @nethserver-base
    Dep-Install nethserver-antivirus-1.1.3-1.ns6.noarch       @nethserver-updates
    Install     nethserver-backup-config-1.4.2-1.ns6.noarch   @nethserver-updates
    Install     nethserver-backup-data-1.1.5-1.ns6.noarch     @nethserver-updates
    Dep-Install nethserver-c-icap-1.0.2-1.ns6.noarch          @nethserver-base
    Install     nethserver-cgp-1.0.0-1.ns6.noarch             @nethserver-base
    Install     nethserver-collectd-1.2.0-1.ns6.noarch        @nethserver-base
    Install     nethserver-collectd-web-1.0.2-1.ns6.noarch    @nethserver-base
    Install     nethserver-dnsmasq-1.5.1-1.ns6.noarch         @nethserver-updates
    Install     nethserver-firewall-base-2.7.1-1.ns6.noarch   @nethserver-updates
    Install     nethserver-httpd-2.4.2-1.ns6.noarch           @nethserver-updates
    Dep-Install nethserver-lsm-1.0.2-1.ns6.noarch             @nethserver-updates
    Install     nethserver-ntopng-1.2.3-1.ns6.noarch          @nethserver-updates
    Dep-Install nethserver-redis-1.0.0-1.ns6.noarch           @nethserver-base
    Install     nethserver-restore-data-1.0.0-1.ns6.noarch    @nethserver-updates
    Install     nethserver-squid-1.3.7-1.ns6.noarch           @nethserver-updates
    Install     nethserver-squidclamav-1.1.0-1.ns6.noarch     @nethserver-base
    Install     nethserver-squidguard-1.3.1-1.ns6.noarch      @nethserver-updates
    Dep-Install nfs-utils-1:1.2.3-54.el6.x86_64               @centos-base
    Dep-Install nfs-utils-lib-1.1.5-9.el6_6.x86_64            @centos-updates
    Dep-Install ntopng-2.0.150531-164.x86_64                  @nethserver-updates
    Dep-Install ntopng-data-2.0.150531-164.noarch             @nethserver-updates
    Dep-Install numactl-2.0.9-2.el6.x86_64                    @centos-base
    Dep-Install openpgm-5.1.118-3.el6.x86_64                  @nethserver-base
    Dep-Install perl-CGI-3.51-136.el6_6.1.x86_64              @centos-updates
    Dep-Install perl-Config-General-2.52-1.el6.noarch         @centos-base
    Dep-Install perl-DBI-1.609-4.el6.x86_64                   @centos-base
    Dep-Install perl-Digest-SHA-1:5.47-136.el6_6.1.x86_64     @centos-updates
    Dep-Install perl-RRD-Simple-1.44-1.el6.rf.noarch          @nethserver-base
    Dep-Install ppp-2.4.5-5.el6.x86_64                        @centos-base
    Dep-Install python-GnuPGInterface-0.3.2-6.el6.noarch      @nethserver-base
    Dep-Install python-boto-2.5.2-3.el6.noarch                @nethserver-base
    Dep-Install python-crypto-2.0.1-22.el6.x86_64             @centos-base
    Dep-Install python-paramiko-1.7.5-2.1.el6.noarch          @centos-base
    Dep-Install redis-2.4.10-1.el6.x86_64                     @nethserver-base
    Dep-Install rp-pppoe-3.10-11.el6.x86_64                   @centos-base
    Dep-Install rpcbind-0.2.0-11.el6.x86_64                   @centos-base
    Dep-Install rrdtool-1.3.8-7.el6.x86_64                    @centos-base
    Dep-Install rrdtool-perl-1.3.8-7.el6.x86_64               @centos-base
    Dep-Install samba-common-3.6.23-14.el6_6.x86_64           @centos-updates
    Dep-Install samba-winbind-3.6.23-14.el6_6.x86_64          @centos-updates
    Dep-Install samba-winbind-clients-3.6.23-14.el6_6.x86_64  @centos-updates
    Dep-Install shorewall-4.6.4.3-1.el6.noarch                @nethserver-base
    Dep-Install shorewall-core-4.6.4.3-1.el6.noarch           @nethserver-base
    Dep-Install squid-7:3.3.13-1.el6.x86_64                   @nethserver-base
    Dep-Install squidGuard-1.4-9.el6.x86_64                   @nethserver-base
    Dep-Install squidclamav-6.10-1.ns6.x86_64                 @nethserver-base
    Dep-Install yajl-1.0.7-3.el6.x86_64                       @centos-base
    Dep-Install zeromq3-3.2.5-1.el6.x86_64                    @nethserver-updates
Scriptlet output:
   1 /etc/squid/squidGuard.conf created as /etc/squid/squidGuard.conf.rpmnew
   2 Setting up redis auto startup
   3 Creating link under /usr/local/bin
history info

(Stefano) #16
[root@neth ~]# rpm -q --whatrequires samba
nethserver-samba-1.5.4-1.ns6.noarch
[root@neth ~]# rpm -q --whatrequires nethserver-samba
nessun pacchetto necessita di nethserver-samba
[root@neth ~]# rpm -qa | grep samba
samba-winbind-3.6.23-24.el6_7.x86_64
nethserver-samba-1.5.4-1.ns6.noarch
samba-winbind-clients-3.6.23-24.el6_7.x86_64
samba-3.6.23-24.el6_7.x86_64
samba4-libs-4.0.0-67.el6_7.rc4.x86_64
samba-common-3.6.23-24.el6_7.x86_64
samba-client-3.6.23-24.el6_7.x86_64
[root@neth ~]# rpm -q --whatrequires samba4-libs
nessun pacchetto necessita di samba4-libs

#17
[root@microserver ~]# rpm -q --whatrequires samba
no package requires samba

:cold_sweat:

[root@microserver ~]# rpm -q --whatrequires samba-common
samba-winbind-3.6.23-24.el6_7.x86_64
[root@microserver ~]# rpm -q --whatrequires samba-winbind
samba-winbind-clients-3.6.23-24.el6_7.x86_64
[root@microserver ~]# rpm -q --whatrequires samba-winbind-clients
samba-winbind-3.6.23-24.el6_7.x86_64
samba-common-3.6.23-24.el6_7.x86_64
[root@microserver ~]#

This is the dog that bites its tail


#18

So … What’s happen here?

Is a future update can install KDE or Gnome on NEthServer? :laughing:


(Gabriel GHEORGHIU) #19

Jim,
Please read about Samba here: https://www.samba.org/
You will find interesting and maybe unknown things.
We are not in the Twilight Zone even we are using Linux! :wink:


#20

I know what is Samba… It’s not only a Brazilian dance :laughing:

I want to know what it’s doing on my system where It was not installed because I don’t use it.

IJust think ( yes, I do ) about AFP…I will investigate if AFP bring this stuff :smirk: