Strange Internet connection behavior on Android Phone

Hi guys! Sorry for bother you with something so trivial and for my bad English, but I’m new in the Linux world and especially to Servers, and this is really driving me crazy and I do not know how to diagnose the problem because it’s pretty weird (and I’m newbie):
It turns out that my cell phone (LG G5 Android 7.0) loses connectivity to the Internet, and the way to fix it is by entering the server console and executing the “ping cell phone IP” command.
Only with that I manage to restore the internet connection on my cell phone. No Server, Router or cell phone restart works.
From the cell phone you can access the server interface via web, you can ping other computers, but not internet domains. I tried others DNS, changing Wi-Fi router parameters, assigning a fixed IP and manually configuring all options, I even made a factory reset on the phone, but nothing works. What is even more strange is that my Notebook works without problems, and also uses the Wi-Fi connection.
As a test I installed ClearOS, and it was running for 3 days without presenting this problem. Then I reinstalled NethServer 7.5 several times, but the same thing always happens to me.

Could someone guide me on what may be happening? And why does the ping command restore the connection?

Thanks in advance!

Do you notice anything in the NethServer logs? Have a look at /var/log/messages
I have 7 android devices on my network (2 tablets and 5 phones) and they all work flawlessly using NethServer as DHCP, DNS and Gateway.

I tried, but I didn’t found anything special related to that, but I’m not sure… Maybe you can take a look at but I really don’t want to make people “lose” their time in this episode of Stranger Things… anyway, I found this in the log:

Nov 11 19:07:28 nethserver dnsmasq-dhcp[1332]: DHCPDISCOVER(br0) ac:0d:1b:b8:f0:35
Nov 11 19:07:28 nethserver dnsmasq-dhcp[1332]: DHCPOFFER(br0) ac:0d:1b:b8:f0:35
Nov 11 19:07:28 nethserver dnsmasq-dhcp[1332]: DHCPREQUEST(br0) ac:0d:1b:b8:f0:35
Nov 11 19:07:28 nethserver dnsmasq-dhcp[1332]: DHCPACK(br0) ac:0d:1b:b8:f0:35 android-64c0df3417ec3e90

And here is the complete file (1.7MB).

Okay, I know my problem is not important and relevant to the NethServer world, but I think my problem is some sort of “bug” that appear when I install extra modules for the server (from official and testing/community repositories).
Right now my wi-fi connection is working on my cell phone for about a day and a half.
I made a clean installation of NethServer 7.5 and I only added this software: Basic firewall / Fail2ban / Intrusion Prevention System / UPS support
The log file is a more clean rigth now, I can even understand a little what is happening.
I will keep testing the server for some days and then I will start adding others modules that I want to test or use, like Apache+Wordpress, SoGo, etc., but one by one, and testing for at last 2 days every module, to see if my cell phone start dropping the internet connection. Maybe I can find the problem to avoid it.
I want my NethServer running in my home for my personal work project, because is imperative for me to save money an learn at the same time.

Thanks for reading.

If this is happening because of one or more modules or applications you installed on NethServer, we absolutely do want to know if/when you find out what the root-cause was of this behavior.

Please report back when you find out!

1 Like

Could it be you configured the IPS to block all?

Thank you! I will do it. Hope I can help with something to this wonderful community.
I will keep you informed, when I found something.

Right now is installed but not activated, and I don’t remember if was running before (I have reinstalled NethServer like 5 times and I lost the track).
I’m going to be honest, it seems to me that I always installed the module but never activated it … or at least I didn’t change the default configuration.
Anyway, maybe it could be the problem. But is strange, because I lose internet connection in the cell phone and with a simple ping to the IP is restored, I’m not sure if Suricata IPS works like that…
I will pay attention to that and I will configure it like the link you provide me.

Thanks you for the advice!

1 Like

Hi Damian,

Just out of curiosity :grinning: ; how did you implement the wifi infrastructure?
Your logs show the NS instance is your DNS server… Which (kind of) device provides the wireless services?

Hi Mark, I have a “TP-Link TL-WA901ND” connected to my " 3Com Switch" and configured with static IP Subnet Gateway and DHCP Server disabled.
I use the NethServer DHCP server for asign clients IP (mostly Wi-Fi users, because my Desktop computers use static IP). The configuration is:
IP range start: / IP range end: / Gateway IP: / Lease time: 43200 / Domain: / DNS servers, / WINS servers: / NTP servers: / TFTP servers:

I think in my case WINS, NTP and TFTP are irrelevant, but in a desperation move I’m trying anything…

Is this information what are you asking?

P.S.: Log from first post is not my actual server because I reinstall it. But I can easily end up with same configuration because I really don’t know nothing (like Jon Snow :smile:).
P.S.2: I’m now trying a new subnet 192.168.10.x for the Server and clients. Before I was using 192.168.0.x

Yes, this most definitely helps to analyze the strange behavior you are experiencing.
My curiosity was also set whether a flunky (internal) wifi adapter in your server going into power-save could be the issue (I had my share of those…) Its clearly not the case :

Is an proper access point, not even a router acting as AP. Meaning no mis-configuration to be expected here. :thinking:

To be frank, I have no clue.
You may try to set the IP of the AP itself to Dynamic IP(DHCP) to ensure Nethserver is aware of this device. But this a (hopeless) longshot…

1 Like