[SOLVED]Sogo+AD+Chinese Typo on sogo.conf - I do not understand

To put this on SOLVED please mark an answer as solution, check this:

https://community.nethserver.org/t/howto-mark-a-topic-as-solved/1750

1 Like

Done.
Thanks again

Hi Zwordi,
I think you got it wrong, your answer

should be the solution, not the answer of Markus “How to mark an answer as solution”.

1 Like

Fix Thanks

1 Like

can we mark this as a bug, or an undocumented feature ?

I’m facing the same issue here…
what I see is that once joined the domain, sogo.conf has the binary password even if I set a bind password… a nethserver-sogo-update event solve the issue…

digging a bit, I see that sogo.conf file is not expanded when I save the bind credentials… the Save button only stores the credentials into the db…
I’m not sure this is the right way to do… IMO, the save button should invocke the nethserver-sssd-update event and sogo should have its template expanded (and service restarted) in sssd-update event
my 2c

It has been recorded as a note in our project page (GitHub auth required) for months. Thanks for pushing it!

Now it’s filed as new issue here: https://github.com/NethServer/dev/issues/5365

There’s an action in event nethserver-sssd-save that searches usage of “NethServer::SSSD” and invokes the “update” event of dependent packages automatically. It’s a weird hack to avoid subscribing the event (and recompile) many packages when SSSD came out.

/etc/e-smith/events/nethserver-sssd-save/S80nethserver-sssd-notifyclients

Perhaps nethserver-sogo does not match the search filter? If that’s the case the fix could be subscribing the event.