Solved - Inception in "Bandwith usage" category


I just heard of your project and tried briefly the Demo server this project seems really interesting! While playing with every button on your demo I came across a strange behavior of the webUI. In the “bandwith usage” category / tab, i seem to be able to make a new webUI appear where the reports should appear. I can then reproduce this behavior to produce webUI in webUI multiple times (i did the following screenshot with 2 webUI within each other).

Steps to reproduce:

  • go to the demo server and login (
  • go to the Bandwith usage category, it should only display the “settings” button
  • click the settings button and the on the next screen click “back”
  • when the page reload, you get the “settings” button at the top (expected) and and new embeded nethserver webUI.

You can repeat the steps in the new embeded webUI to make even more inceptions of the nethserver webUI.
It appear that the embeded webUI is only displayed in the “bandwith usage” category and in the “web proxy stats”.

I search the forum for a similar bug but couldn’t find one. If it isn’t a bug or an already known bug, please feel free to redirect me to the original bug report and close this topic.

It is now quite late and I am a bit tired so sorry for not investigating more than I already did. If you want more precision I will be glad to answer.


1 Like

Thanks for taking the time to report it. You’re welcome.

It’s and old bug (fixed long ago), but the demo still uses a docker image with an old NethServer version that needs to be updated.


Thanks for the answer, I placed “Solved” in the title. If I have to do something else to close that thread let me know.