[SOLVED] Cannot use Backup to backup to AD authenticated shares

NethServer Version: NS 7.4.1708
Modules: Backup, File Server, and AD (though see below)

Hello,

So I’ve run in to an off situation.

I have three NS boxes:
Neth-Nexus which serves as the primary AD domain.
NethFS1 which has a shared folder via File Server with Backup installed and is joined to the AD domain.
NethFS2 which has a shared folder via File Server with Backup installed and is also joined to the AD domain.

When creating shared folders on either NFS1 or NFS2, I can successfully set what group has access to the folders as inherited from the PDC’s list of users and groups. As an authenticated user, I can read and write to those shares at will.

When using Backup from NFS1 to NFS2, and selecting a Windows Share with the correct credentials, the backup fails. The Backup log shows the following error: “mount error(5): Input/output error”. Generally, I know that to mean there is a problem with credentials. I have tried the following for credentials:

correctuser@mydomain.com
DOMAIN(NetBIOS name)\correctuser
correctuser

I know the password is correct. I have triple checked the file permissions on the folder I am meaning to write to and have even used the “Reset permissions” button.

Clearly I am missing something here. Can someone give me a pointer as to what I am doing wrong? Theoretically, I could setup an NFS share and get around this but I would like to stick to the GUI so that I can show other users that NS can be wholly used from the WebUI easily.

Please try

correctuser,domain=mydomain.com

This works for me.

4 Likes

That did the trick. Thank you very much! That should probably be documented somewhere.

3 Likes

I’ve opened a pull request for the documentation at github.

https://github.com/NethServer/docs/pulls

4 Likes

Thank you @m.traeumner. I merged your PR, slightly modified. I hope you don’t mind.

2 Likes