[Solved] Backup-data fails in pre-backup

NethServer Version: 7.5.1804
Module: Backup-Data

Hi, I’ve just started using NethServer and configured with Firewall, Squid and Samba (AD). Everything is working perfectly, except for the data backup. Whenever I try to do one it returns me an error.

What I have tried to do:

  • Reboot the machine
  • Uninstall and reinstall the backup-data module
  • Change from Incremental to Complete and then the other way around
  • Changed the external HD I’m trying to use to another one (formated as FAT)

My backup log shows:

Backup: backup-data
Backup started at 2018-11-12 10:35:01
Event pre-backup-data: FAIL
Backup status: FAIL

The same have happened when I tried a manual backup.

I have searched for someone with the same error, but most of those who are having errors with the data backup are doing it with a Network share as destiny. Besides, most errors I’ve encountered are related to some fail during the backup, not before it even starts.

Anyone ever had this error? I’d be really glad if anyone could help me.

Hi André,

welcome to Nethserver Community.

FAT is supported but not recommended, you may try EXT3/EXT4:

http://docs.nethserver.org/en/v7/backup.html#usb-disk-configuration

Maybe there is some more information about the error in /var/log/messages?

2 Likes

Changing the format to ext4 solved the problem! Thanks!

1 Like