SOGO: "Failed to change flags of IMAP4 Message"

NethServer Version: 7.2009
Module: nethserver-sogo


I have a SOGo user that is reporting intermittent 503 errors while using SOGo (mainly while clicking between messages), and as recently as this morning is reporting issue uploading multiple attachments. I’m not able to find any errors in the log files for SOGo.

The error message the user is seeing is “Error while uploading the file ‘****.doc’: Failed to change flags of IMAP4 message.”

I have tried replicating these issues both from an administrator account, and a user account we use for diagnostics, neither of which show the same result. I’m wondering if anyone would have any insight on what might be causing this issue, and/or any log files that might be worth checking, as neither Postfix/Dovecot or SOGo logs appear to have any information on the error.

Alternatively, the user did report that they were able to send each file individually and each attachment uploaded and sent fine. It was just when trying to upload multiples.

Prob a long shot, did you check available storage?

Yes, the server in question is only using about 30% (271GB) of it’s allocated 922GB of storage.

Message size limit?
.doc is quite old and space-wasting format. .odt is much more compact and… eve .docx is.

The attachments themselves were all fairly small, 52kb, 55kb, 56kb, and 64kb in size respectively. Which would still be relatively small.

Postfix returns the following:

postconf -d | grep message_size_limit
   message_size_limit = 10240000

In the Nethserver GUI, max message size is set to 500MB. 90% of emails on this instance are sent internally, so file size isn’t a major concern, which explains the lax file size restrictions.

Some sort of a timeout maybe when cumulative files size transfer?

This is possibly what I am thinking but I can’t find any evidence of a timeout in the log files, nor can I find any configuration that may be contributing to this issue.

Doubtful, but could this attribute to these types of issues?

Many years ago a similar error (but with a more verbose message) was due to missing IMAP Capabilities (UIDPLUS extension) when using an older mail server version, but this should no longer be the case.

Does the error happens only with a specific account?
On an specific computer or any?
On different browsers?

Does the error happens only with a specific account?

  • One user account has consistently reported the issue. No other users have reported similar issues.

On an specific computer or any?

  • It appears to be only this user, and each device this user is using.

On different browsers?

  • The user has tried different devices, all with the same result.

Additionally, I know this will be asked, so I’ll provide it now.
SOGo is version 5.7.0

Is there any difference between this user (the server entity) and other users not having this issue?

I’m assuming you mean permission-wise? In that case, no. This is a standard user. The only difference between this user and others is that this user is the member of a few specialized groups, but there are multiple others who are part of the same group that do not have this issue.

Sorry to point again in this direction: is there at least another one user which is in some way “the twin” of this one, in the same exact group combination?

There are about 15 of them. This user is the only one having this issue, and it’s only in SOGo.