Sogo 2.2.15 is available to test

Preferences -> Account -> New Account -> Exchange
Happy test! :smile:

I already tried but my phone doesn’t included exchenge account (i don’t know why). I downloaded activesync app and it works well.
Ciao

Has Anyone tested it? Any hint? :wink:

Yes @alefattorini I have spent all this afternoon preparing the environment but above all trying to connect my Outlook 2010 with SOGo 2.2.15 with no results.
After updating my 2.1.1b SOGo installation I followed instructions here http://www.sogo.nu/files/docs/SOGo%20Native%20Microsoft%20Outlook%20Configuration.pdf

Outlook ask me for credentials but nothing more.

Can anyone give me some help? :frowning:
Can anyone tell me steps to troubleshooting this behavior, which logs services ports etc.?
Thanks.

@sitz make sure (rpm -q) that your nethserver-sogo version is >= 1.4.1-1.15.gcba4b05
If you have NS 6.6, 1.5.0-1 is available since yesterday.
open in your browser https://NS_IP/Microsoft-Server-ActiveSync you should see this message

An error occurred during object publishing
reason for HTTP error unknown

then try to configure an organization account on your Android device calendar. If it works, it’s an Outlook configuration issue and I’m not able to help you anymore :slight_smile:
If on your browser you have this error:

Not Found
The requested URL /Microsoft-Server-ActiveSync was not found on this server.

new httpd configuration is not properly deployed…and it means that I’ve done something wrong :grin:

2 Likes

Hi @Stll0 my test environment is built on NethServer 6.5 with this version of SOGo

 [root@v-nethserver ~]# rpm -q nethserver-sogo
 nethserver-sogo-1.4.1-1.16.gd58c5e7.ns6.noarch

With my Android device ActiveSync synchronization works fine and I’m agree with you that it could be an Outlook issue but I didnt’ask some help for Outlook but how to troubleshooting correctly this kind of situations.

Before troubleshooting, do you suggest me to undate to NS 6.6 and latest SOGo release?
Thank you for your help.

I’ve asked about Android to figure out if it could be server or client issue. If it was server, I could dive into trobleshooting with you, but I’m completely ignorant on outlook…

[quote=“sitz, post:18, topic:203”]Before troubleshooting, do you suggest me to undate to NS 6.6 and latest SOGo release?Thank you for your help.
[/quote]
It’s the same for your purpose.
But focus on client side. I’d bet on some self-signed certificate related issue.

Keep a look to this http://www.sogo.nu/files/docs/SOGo%20Installation%20Guide.pdf especially the ActiveSync tuning part

Some parameters are db nethserver props yet, so it’s easy to manage them
http://dev.nethserver.org/issues/3063#note-2

Hi Everyone,
the issue is related to the outlook version, outlook 2010 did not work with active sync, only Outlook 2013 does.
To use outlook 2010 openchange is needed, and I understood that in NethServer is not configured.
Let me know if I’m wrong, I’m trying to connect outlook 2010 with no results too…

Die outlook…even microsoft wants to kill outlook

3 Likes

We’re not speaking about openchange here, but just Active Sync support. I’m trying out a few tests and I’ll let you know

@sitz i guess that the problem is the first sync with a lot of data (mail and calendar) can you try it with an empty user
profile?

Not correct @alefattorini but I didn’t explain correctly the problem.
Outlook 2007/2010 ask me for credentials but after about 30 seconds it prompt to me a message that:"…is unable to contact Exchange server."
@Stll0 did a bet about some self-signed SSL certificate issue, I tried to install SSL certificate in Windows (trusted organizations) but Outlook 2007/2010 still was unable to contact the server.

Below a quick report of my test(s) on NetServer 6.5 with SOGo 2.2.15:

  1. Outlook 2007/2010 ask me for credentials but they are unable to find Exchange server (SOGo). Tested on two different PC with two different domain configuration and Microsoft Office version.
  2. Outlook 2013 just works fine connection, e-mail, calendar, address book then I cried for tension
  3. Android devices works fine

I have to test Apple devices.

I don’t give up with Outlook 2007/2010.

Do you tried out with and empty profile? Or full of data? How much data?

Yes sorry @alefattorini I forgot to report this, completely empty profile on the server side, on the client side (since Outlook 97) I always “Add new profile” starting from scratch.

Exactly what I’m saying,


Outlook 2003, 2007, 2010 don’t work with activesync.
I’ve tested sogo 2.2.15 on NethServer 6.5 and it works on Aplle devices with ios 8.1.
In my tests I used an account with 500Mb storage and it works good.
Hope it helps, ciao

You’re right :wink: good to know about your tests. Do you have tried Outlook 2011 with the same account? (500mb)

I moved 4 posts to a new topic: Language not found error accessing SOGo

standing ovation !!!

I moved 3 posts to a new topic: Is activesync available in NethServer 6.6 and SOGo?

I moved a post to a new topic: Activesync synced just 1 month of my calendar on Android