Software Center Modules No Longer Show Up

I have been bouncing around between FreeNas, Ubuntu Server, Nethserver, etc… trying to find a server software solution. The feautres I am looking for is a file server that also provide cloud access to those files. I would also like to have single sign on capability that allows a user to access any machine in the network and have the same interface. This was available on Nethserver 6.8 I believe, and it worked great.

I have been trying really hard to like Nethserver. I believe it is the best solutiion for me. I have attempted several times to use Nethserver for my default server, but I run into issues each time.

First, it was that I was waiting on Nethserver 7 to run the new version of OwnCloud. Then, once beta was released I installed Nethserver to find that OwnCloud was no longer supported due to moving to Next Cloud. At the time, there was no module available to install Next Cloud.

Now, I am test driving Nethserver 7 in a VM, and I read that I can only set permissions on files using Samba Active Directory not OpenLDAP. So, I reinstalled Nethserver and installed the Samba Active Directory and configured it with a IP address and bridged interface as instructed in the guide. Now, when trying to access the Software Center nothing shows up and I get:

“The install/update may have failed due to metadata caching issues. Please clean the cache by clicking the button below and retry the install/update operation.”
“CLEAR YUM CACHE”

Clicking “CLEAR YUM CACHE” does nothing and I cant install Nextcloud or a file server or anyting else for that matter.

I would really just like to find an easy to use server solution, other that Windows, that can provide the service I am looking for. I really want it to be Nethserver, but I really am tired of hitting problems at every turn.

Can someone please help me?

Hi. Do you have a network connection with your installed Nethserver instance?
This YUM CACHE-Message is also shown if you have no network connectivity. Try to ping something in the network from your Netserver or vice versa.

yes i have a network connection. I am able to ping all networked computer and access the gui interface. This only occurred after having installed the samba active directory module to administer users and groups.

And the connection to the internet from the Nethserver is also working?

absolutely. it is not a problem with the networking. installing the module broke something in the software and i am unsure how to proceede to fix it

1 Like

@davidep, @filippo_carletti, @Stll0: nethserver-samba createlinks source code file seems to be truncated.

Are you referring to this? It seems correct to me.
https://github.com/NethServer/nethserver-samba/blob/master/createlinks

My fault. Downloaded the package from the repo and opened the file with gedit with text wrapping enabled, and it didn’t show the last lines (even when using the cursor or CTRL+END)

The file is correct, sorry for the inconvenience.

Any error on the logs?

PS, NEXTCLOUD has no leg to stand on when it comes to OwnCLOUD. You cant do without NEXT CLOUD…
I just wish that we could incorporate MATTERMOST INTO NETHSERVER… HINT HINT

I had this same problem with the YUM Cache error at First, Included with that the NO software listed in the Software center…

So It was off to the Good old Dark Screen CLI log in, SSH into the system,

Log in as the Root,
-> YUM UPDATE.
And try it from their. It solved all of my problems except one… :frowning:

The Server still doesnt make me coffee

I don’t really understand what you are trying to say here.

1 Like

Hell @Wirez82, i wanted to know if there may be a chance that mattermost, (the slack alternative) may be a package on Nethserver.

Thanks clinton

Do you mean Nextcloud? Check out the V7 Beta. It’s already available.

Thanks, no I know that. Im already using nextcloud its a dream. I mean mattermost

I am on a wifi connection.