Software center - mail on updates available has stopped

So what is the result? I can’t change anything, it is what it is. I won’t get any mails from Software center?
I don’t really like this behaviour… :thinking:

Only if you set them to be. Automatic updates don’t come with the subscription.

Some additional information:
Last mail from NS regarding updates I’ve received on 09. Feb 21 from user ‘root’ with subject line “Yum: Updates Available on”. After that day we buyed & installed a subscritption und made update to NS 7.9.
Is there a way to reactivate this behaviour? Possibly configuration via the console (not from the cockpit menu)? Are cron or yum involved here?

The subscription doesn’t suppress any mail and yes, it’s something with yum-cron.
When yum-cron cron generates some output, cron will send the mail: I have plenty of them on my inbox from machines with subscriptions.

Take a look at yum-cron config, what’s the output of grep email /etc/yum/yum-cron.conf?

Hi @giacomo,
the output of your command is

# How to send messages.  Valid options are stdio and email.  If
# to have cron send the messages.  If emit_via includes email, this
# program will send email itself according to the configured options.
emit_via = email
# The address to send email messages from.
email_from =
email_to =
# Name of the host to connect to to send email messages.
email_host = localhost

Inside the folder /etc/yum/ I see two config files, yum-cron.conf and yum-cron-hourly.conf.
I have edited the file yum-cron-hourly.conf to to this:

#update_messages = no
update_messages = yes

#emit_via = stdio
emit_via = email

Don’t know about the purpose of the second file… I am waiting for the next updates to see, if anything has changed in behaviour. :slightly_smiling_face:

So everything is in place to send mails.

In case you will not receive notifications, you should inspect the mail server log.

OK, I will report results here…

1 Like

Good morning to all!
New results from me: I did not receive mail from new updates, which are available on my NS.
I wonder if the cron job for yum updates is active… I should check this.
My log files are quite large, what should i look for to find failures in cron or yum regarding not sending mails if updates available?

Assuming updates are involved daily I’ve looked into folder /etc/cron.daily. There exists the file 0yum-daily.cron. Inside this file exec /usr/sbin/yum-cron is called. So far so good, but which config file is used for this call? In the web I have seen something like this:

exec /usr/sbin/yum-cron /etc/yum/yum-cron-hourly.conf

Does NethServer need a parameter (config file) for calling yum-cron?
If so, which config file?

  1. /etc/yum/yum-cron.conf
  2. /etc/yum/yum-cron-hourly.conf
  3. /etc/yum.conf

In the other hand- which is the default configuration?

Hi @giacomo,

may be this is the problem:

It is something with coding in US-ASCII / UTF8…
What do you think?

This one: /etc/yum/yum-cron.conf


yum-cron-hourly is disabled, yum-cron (daily) is enabled.

I dot not think so: If yum-cron crashes, the output is catched by cron an sent by mail.

Search for mail sent by root:

grep root@$(hostname -d) /var/log/maillog

I’ve got it!! Here is the solution:

First I have edited the file /etc/yum/yum-cron.conf to change parameter "random_sleep = 360" into "random_sleep = 0" (for test purposes only!).
After that I called yum-cron manually in a console with result:

Failed to send an email to localhost: {‘’: (504, ‘5.5.2 : Sender address rejected: need fully-qualified address’)}

So the fact is yum-cron needs a fully-qualified address with myhost.mydomain.TLD!

After changing…
email_from = to email_from =
email_to = to email_to =

… I receive mails from yum-cron.

Last thing I would like to do is making scripts / templates for automation…
Any hints for me which templates I have to add…?

thank you for your effort!

You should configure a correct domain name.

Eventually you can create a template-custom for /etc/e-smith/templates/etc/yum/yum-cron.conf/30email

You are right, the “” is not our real domain name…
Next days I will give it a try with a template, many thanks!

Kudos to this community here, I am a fan of nethserver and linux in general :smiley: :+1:


I have edited /etc/yum/yum-cron.conf manually (changed email_from =… and email_to =… , you know). But this will always get lost every night. The reason is:

Mar 29 03:49:02 mail esmith::event[54933]: Event: software-repos-save
Mar 29 03:49:02 mail esmith::event[54933]: expanding /etc/nethserver/eorepo.conf
Mar 29 03:49:02 mail esmith::event[54933]: expanding /etc/nethserver/pkginfo.conf
Mar 29 03:49:02 mail esmith::event[54933]: expanding /etc/yum/yum-cron.conf
Mar 29 03:49:02 mail esmith::event[54933]: expanding /etc/yum/vars/nsrelease
Mar 29 03:49:02 mail esmith::event[54933]: expanding /etc/yum.repos.d/NethServer.repo
Mar 29 03:49:02 mail esmith::event[54933]: expanding /etc/yum.repos.d/subscription.repo
Mar 29 03:49:02 mail esmith::event[54933]: Action: /etc/e-smith/events/actions/generic_template_expand SUCCESS [0.421979]
Mar 29 03:49:02 mail esmith::event[54933]: [NOTICE] eorepo sb-base sb-updates sb-epel sb-extras sb-centos-sclo-rh sb-centos-sclo-sclo sb-nethserver-base sb-nethserver-updates
Mar 29 03:49:03 mail esmith::event[54933]: Loaded plugins: changelog, fastestmirror, nethserver_events
Mar 29 03:49:03 mail esmith::event[54933]: Cleaning repos: sb-base sb-centos-sclo-rh sb-centos-sclo-sclo sb-epel sb-extras
Mar 29 03:49:03 mail esmith::event[54933]: : sb-nethserver-base sb-nethserver-updates sb-updates
Mar 29 03:49:03 mail esmith::event[54933]: Action: /etc/e-smith/events/software-repos-save/S20nethserver-base-software-repos SUCCESS [1.307214]
Mar 29 03:49:03 mail esmith::event[54933]: Action: /etc/e-smith/events/software-repos-save/S21nethserver-base-import-repokeys SUCCESS [0.0185]
Mar 29 03:49:03 mail esmith::event[54933]: Event: software-repos-save SUCCESS

I could verify this behaviour after editing yum-cron.conf again and then calling

signal-event software-repos-save

So I think the only way to save my changes permanently is to create the right template…

I copied
Now I can edit this file:


This line is important:

email_from = root@{$SystemName}.{$DomainName}

Now everything works the way I want it to. I will wait one more day to see that the mail arrives, then I will install the updates.
Maybe, but this solution is not perfect. Hints and advice are always welcome…
:slightly_smiling_face: :sunglasses:

1 Like

Hmmm, some time has passed - new updates arrived but I still don’t get automatic mail from yum-cron that new updates are available???
What is wrong? I thought everything was working, but it doesn’t seem to be.
… file /etc/yum/yum-cron.conf has right settings. If I change "random_sleep = 360" into "random_sleep = 0" for test purposes and then calling yum-cron manually I get mails for updates available…

1 Like

After a few days’ holiday at Easter, I tried the following:
I made a second (additional) template file… copying

/etc/e-smith/templates-custom/etc/yum/yum-cron.conf/10commands .

Inside the file I changed parameter

random_sleep = 0

and the miracle happened: next day I received automatic mail from yum-cron that new updates are available!
I’m afraid I don’t know what makes the difference between 360 and 0 from the random_sleep parameter…
I hope this is now the final solution. Maybe someone can explain the behaviour, but for now I’m glad it’s working…

If I recall correcrly, more or less, it is the time (in minutes) so multiple servers do not run yum-cron at the same time (consuming bandwidth) or hit remote servers at once.

After all adjustments I described so far, the problem occurs again. It has worked for a few weeks, but now I don’t get mails from yum-cron if it was called by the cron task.
If I run yum-cron from console (manually), I get mails with information for updates available!!

What can I do, how do I find the cause?