Slow web proxy operation

I’m not the author of the post…


@Valeriy Did you solve it?

1 Like

the problem is not solved

Did you try it?

If you’re using Squid cache, check logs inside /var/log/squid/cache.log and search for errors.
In this case, please empty the cache from the web interface and retry.

very much everything is written. I can not understand what needs to be done in the end.

I have to do it?
mkdir -p /etc/e-smith/templates-custom/etc/squid
echo “dns_v4_first on” >/etc/e-smith/templates-custom/etc/squid/91ipv4dns
signal-event nethserver-squid-save

This is to create the custom template and fill in that squid uses ipv4 dns first.

You should give it a try

I followed the recommendations, but it did not help.

@Valeriy Are there any errors?

I do not use cache

@giacomo Any other idea?

Really no other idea here, I feel this is not a problem strictly related to squid itself.

Performance problems are the hardest to debug.
It’s crucial being able to reproduce it, but @Valeriy never succeeded.
He has to find the problem, we will find a solution.

Have you tried it with an other computer which is not bypassing the proxy? If the other computer don’t have the same problems, it’s a problem of the computer. Otherwise you could try to setup a virtual mashine with a new nethser installation and try if there are the same problems.

How many RAM does your Nethserver have?

Same issues here, cant use proxy because half the time the pages never load or they take a long time to load.

How is your squid configured? Transparent or not, virusscan active?
Have you tested it with more than one pc. Is it everywhere the same issue?

I have Transparent with SSL, cache is on but Ive tried turning it off. It will work with pc and not phone, then pc will stop working, ill re enable it and post a log when it happens again. My way around it is to use hosts without proxy. Proxy will not work at all with smart home devices or speakers, so my smart hub, google home, my android tv boxes, anything that pulls dhcp just doesnt work. So I set all devices that arent computers under hosts without proxy.

1 Like

CPU model 2 x Intel® Pentium® D CPU 3.40GHz
8 Gb RAM
2469 / 7823 MB
Free memory
5354 MB)
System version
NethServer release 7.3.1611 (Final)
Kernel release
Lan (green) 1GB tg-3269
Wan (red) 1GB

Prior to installing updates on September 18, 2017, the proxy server worked fine. There were no problems.

This is a really good hint. Please show /var/log/yum.log after September 18.

Aug 10 11:01:19 Installed: 7:squid-3.5.20-2.el7_3.3.x86_64

Sep 14 08:19:58 Updated: 7:squid-3.5.20-10.el7.x86_64

Sep 15 07:51:20 Installed: nethserver-ntopng-1.4.1-1.ns7.noarch
Sep 18 11:57:24 Updated: 7:squid-3.5.20-999.ns7.x86_64
Sep 20 10:01:57 Updated: python2-acme-0.18.1-2.el7.noarch
Sep 20 10:01:58 Updated: python2-certbot-0.18.1-1.el7.noarch
Sep 20 10:02:04 Updated: certbot-0.18.1-1.el7.noarch