Single NIC installation?

You can just change it in web UI “server name”. I have “nethserver.registered.domain” as server name and mailing works.

Did you update? I’d give it a try.

Do your clients get a wrong IP, gateway or DNS via DHCP? Maybe this shows us the error.
You may try to setup a dhcp reservation and change the IP so a fresh IP will be given to the client after dhcp renew.

I am curious to these settings. I wouldn’t be surprised there is a setting off in any of those 3.
Does your client get no IP at all? Can you start troubleshooting from bottom to top based on OSI model?
Check cables, network adapters.
Can you reach localhost from the client? (
Can you reach it’ s own IP address from the client?
Can you reach NetServer on it’ s IP address from the client?
Can you reach NethServer on it’s FQDN from the client?
Can you reach the (default) gateway IP address from the client?
Do sites on the internet resolve correctly from the client?

Please try these tests and check back with the test(s) that are successful and the test(s) that fail.

Are they also in different subnets? (just checking)

Today is a good day. Almost everything is working.
I did let it update all components to latest release when I turned it on - apparently that made no difference.
As it turns out, with all the switching of DHCP between router and Nethserver the devices had a hard time relleasing their addresses. When my answers to all but one of robb’s questions were negative I went thrugh the lot and collected the MAC addresses and created address reservations in Nethserver, restarted all the devices, and voila, it worked (there must be an easier way to type those addresses).
Now remainig is my mail problem.
Server name cannot be changed, presumably because I configured Active Directory. There ought to be a setting for response to Hello or Mail From commands. I hope there is a better option than re-installing with the registered domain as FQDN
Thank you so much for helping me get this far.


1 Like

On the subject of SMTP response to HELO, in MS Exchange there is an option to change the response to a virtual domain instead of the FQDN. Is there some obscure way to accomplish this in Nethserver? If not, maybe there should be.

You probably are looking for this one:

1 Like

If a client has an IP adress through NS DHCP, creating a reservation is as easy as clicking the ‘IP Reservation’ button in the NS DHCP module page.

That is where I looked, but only 4 of 11 devices had checked in and two of those were identified only by MAC address, so I had to check them all and identify them. At least now I have a record of all my devices’ MAC addresses.:grin:

Thanks, I did that, and I am still getting rejections. Following is an excerpt from the maillog:

Nov 14 12:42:52 juliet postfix/smtp[7063]: 4982A6005B82B:,[]:587, delay=6917, delays=6886/0.07/31/0.15, dsn=5.1.0, status=bounced (host[] said: 550 5.1.0 vnielsen@deltaecho.lan sender rejected : invalid sender domain (in reply to MAIL FROM command))
Nov 14 12:42:52 juliet postfix/cleanup[7100]: 8F04D6005B826: message-id=20171114204252.8F04D6005B826@juliet.deltaecho.lan
Nov 14 12:42:52 juliet postfix/bounce[7099]: 4982A6005B82B: sender non-delivery notification: 8F04D6005B826

How do you check the response to helo command? and would that be different from ‘mail from’?

Finally I realized that defining a virtual server was not enough to receive mail from Internet, so I also created mail aiiases for individual users. Since Comcast blocks port 25 I am using a forwarder to send the mail to port 587. I appears that mail is rejected unless I enter the forwarder’s IP in ‘SMTP Access’. Is that correct?

I think that is your issue … mail will (usually, unless the sysadmin is a spammer) only be relayed if the maildomain where the mail originated has a valid MX record. You can not have a valid MX record on internet for this address …

Third-party mailservers will always contact your mailserver on port 25, no amount of redirection will help you there.

1 Like

I do have a registered domain and MX record for it. I am receiving mail just fine via port 587 by using a forwarder. Also, the smarthost would work fine on port 587 if I could find a way to get postfix to give the proper response to the ‘mail from’ command. In MS SBS it is easy, during setup you input the response to the command, and it works!
Unfortunately the approach suggested by giacomo is not working, and I do not know how to check postfix’s output. Took a look at in the postfix directory and it still lists the FQDN. But I am not sure i dare change that to my registered domain.
Any ideas? Suggestions would be greatly appreciated.

How do you get internet to resolve that name?

The registered domain is It seems the general practice is to use a non-registered FQDN for server. This is why, earlier in the thread, I touched upon re-installing and use my registered domain as FQDN since I cannot figure out how to get postfix to respond with registered domain.

(If, like me, you are used to documentation being next to worthless, Nethserver’s documentation really is to the point and lacking little. When in doubt, check the manual :wink: )

1 Like

Good to know this! Our docs team is amazing :slight_smile:

Finally, I found a temporary solution to my outgoing mail problem. it turns out that in Roundcube I can mess with the Identities of the sender and that way I am able to fool the SmartHost.
Unfortunately you cannot do this with Outlook, so I will keep working on it. Meanwhile this issue will be marked as solved.

This should be solved by setting custom ehlo … what issue remains after doing that?

And if you are using a smarthost, shouldn’t that get the custom ehlo ?

Even after the custom ehlo commands the smarthost rejects the messages as invalid sender in response to MAIL FROM command. Server responds vnielsen@deltaecho.lan, but smarthost requires