Server manager accessible on red interface?

v7
server-manager

(Dan) #1

NethServer Version: 7.4
Module: Server manager

tl;dr: The server manager on my Neth 7.4 installation seems to be accessible over the red interface, which doesn’t seem right.

I have Neth 7.4 installed on a Contabo VPS with a single NIC to the Internet. That interface is configured as red. I’ve added a dummy interface following the instructions here, given it an RFC1918 private IP address (192.168.4.1), and configured it as green. I’ve also set up an OpenVPN connection to my home LAN*, and added that network (192.168.3.0/24) as well as my home LAN (192.168.1.0/24) as trusted networks in the server manager.

I first thought it was odd that I could ssh from home to the public IP address of the Neth instance, but didn’t pursue it further. But while traveling last weekend (i.e., away from home, and not connected to the VPN), I found that I’m able to pull up the server manager remotely. Should it be this way? I wouldn’t think so.

  • I wasn’t able to get this working through the server manager, so I uploaded the .ovpn file to /etc/openvpn/client/, enabled it with systemctl enable openvpn-client@pfsense, and started it up with systemctl start openvpn-client@pfsense. It appears to be working properly, though I’d like to figure out how to manage it through the server manager–but that’s another thread.

(Andreas Schloegl) #2

Hello @danb35 did you change the service ‘httpd-admin’ to green role only? This might be the missing point, because based on the installation as described it will be on red interface, then when dummy0 is up it will be on red and green interface. I have tested this here and it works as it should.
you can change the red/green zones from server manager directly (network services). Hope that helps!


(Dan) #3

I did not, as I didn’t realize that would be needed. I’ll adjust and report back. Thanks!


(Dan) #4

That was indeed the issue–I’d assumed that it wouldn’t be available on red, and didn’t realize I’d have to change it. With that change made, it’s working as expected. Thanks!