Rstudio Install instruccions, PAM autentication [SOLVED]

Hello I follow the Rstudio install instruccions from this page:

How to Install RStudio Server on CentOS 7

I have AD in the server machine, everthing is good but when I try to login with an active directory user it does’nt work.


Hello Héctor

I’m not quite sure, but I have a feeling that it could have to do with the SSL Certs used by the NethServer AD.

Even if you have correct LetsEncrypt SSL Certs, the AD uses it’s own, self generated certs, which are not accepted by a lot of Apps.

A solution could be: Copy over the LetsEncrypt Certs over to the NDSC SSL Folder, best done with a software hook on the LetsEncrypt renewal script.

See this post by Elleni, after we had a good discussion and ideas:

This should help with your AD issue… :slight_smile:

My 2 cents


Andy thanks for the instruccions, after a night trying to make AD do the job, I found the way to make it work, It was so simple:

sudo cp /etc/pam.d/login /etc/pam.d/rstudio

So then I can loggin with the SSH enabled user.


Hi @hector,
nice to hear you have solved it, could you please mark the topic as solved?

1 Like