Restore Backup on different hardware

Hello agene

Some new trouble. I now have Nethserver on an old laptop running for a year or 2 now.

The old Laptop has to go. So I bout a NAS-Qnap. The old Laptop maks his backups on the new NAS.

On the NAS i created a virtual machine with NETHSERVER:

I gif the same path to the new and the old NETHSERVER for backup.

I want to restore the old nethserver to the new virtual wan. When i do RESTOR te virtual nethserver dos not see the backups from the old NETHSERVER.

How can i fix this ? Or what am i doing wrong ?
p.s The new virtual NETHSERVER has full axes to the private and internet.

Does the new Nethserver instance have permission from the NAS to access the NAS resources? Have you pinged the NAS from the new NS?

yes i have

in terminal i can see the backup files

start with /var/log/restore.log, or any of the other restore*.log that may have been created, or look at the messages log and see if there’s an error for the path…

ones I had to upgrade Duplicity software, in order to restore 500 GB backup.

Just to clarify… this is Backup (configuration) - Restore… the tab, not Restore Data… you don’t use Restore Data until you Restore the config.

I wonder if he’s restoring 6.7 to 6.8… I haven’t tried that.

“Just to clarify… this is Backup (configuration) - Restore… the tab, not Restore Data… you don’t use Restore Data until you Restore the config.”

That mistake i don’t make again :wink:

It is 6.8 to 6.8

Why is backup restore on a new machine the most difficult thing in Nethserver ??? I am confused

desperate last try for tonight

[root@linux-server ~]# scp -r / root@

so, nothing in the logs?

No nothing: i am wondering if it can haf to do something withe the configuration of the virtual machine and bridged Network ?

But i can aces the virtual machine bij its own ip address and the machine has fun access to internet and local network

What protocol are you using for backup? How about a gui screenshot of the config screen of old NS and new NS, have you checked permissions for the NAS access?
I use cifs and it worked fine, easily, each time I’ve tested it.

I am using NFS for backup. The both machines have the same pro missions and names

can it be that the new machine needs the same ip as the old wane, before i can restore backup ?

In your efforts to perform your restore have you followed the guide?

yes i have.

I have succes now. I had to change the ip address of the new virtual server to the ip of the old server.

I do not understand the reason.

1 Like

Everything is working now. I had to make a full backup from the old server.

Then shutdown the old server. Start the New server. My problem was: For the new server i used a different IP address for the time i was configuration the vm server. I had to change the IP address to the old want. Then the new server was able to restore the backups.

Strange. But i am glad it works