Repair nethserver 7

I suggested a known, working method up above: just convert the vmdk file!
A one liner in Linux on Proxmox.

He said that is not working for him.

too much time, ReaR or Veeam will do the job, it’s not only if i can, but how you get the Goal with best result.

@stojovski

This is his last post as far as I can see?

But I going to look into to convert vmdk into raw and see if I can get it to work.
But it have to be later, is late here in sweden now

So either you do mindreading or have otherwise more info than I do from cazz

Ok it’s ok, calm down

@Andy_Wismer and @stojovski
You both try to help, but which way is the right way for @cazz is his decision. A hint, that veam is payeware is a good hint, but this is not a thread about the best backup software, it’s a thread about transmitting a vm from vmware to proxmox and our goal is to solve his problem.

It is not at all about backup , but if he can boot vmdk on a Esxi, he can just make backup image with one of those 2 , and transfer it on a proxmox, i already done this with ReaR with a lot of systems.And it is quick and reliable.

@stojovski

Veeam does NOT support Proxmox at all. And anyone can retrieve the VMDK file from a running VMWare. (https access)

However, The VMware Server is already reinstalled with Proxmox, so that part of getting the VMDK file is moot. There’s no VMWare anymore.

And a restore without using VirtIO isn’t optimal on Proxmox.

Ok. It is OK.

Hi all
Sorry that I have not have time to try or replay but it have been alot at work :slight_smile:

I think I got it to work but it did take sometime :smiley:

First I did import OVF file into vmware workstation Player and it start up nice and easy.
After that I copy vmdk file winscp from my computer to tmp in proxmox.
Then I did run the convert to raw file.
I then create a new VM with same settings, delete the harddrive that create for the VM
After that I did run "qm importdisk 112 /path/to/your/freebsd/image.raw OS" where OS is there I want to store the raw file.
After that I did go in hardware in proxmox and attach the harddrive to the VM and go into config to active in boot order.

Now it start but still same error so I did try with rescue mode and now it works better then before.
So I did login and then go to the config file of network and change eth0 to vmbr0.
I then "ip link set dev eth0 up" to active network.
The last thing to do is rebuild the kernel and then specify the new kernel and then reboot and now it works.

3 Likes

@cazz
Could you please mark it as solved? It could help other users too.

1 Like

:+1: :+1:

Sure I did forgot about that.
Thanks.

2 Likes