Relay access denied then no web interface

server-manager

(Bill ) #1

I’ve been having a problem with my Nethserver that I think started when I experienced an extended power loss that caused a forced shutdown.

Basically I’ll be using thunderbird and I’ll start to get “refused to connect” messages, then I wont be able to access the NethServer management interface. I can still get to server/nextcloud so I know it’s still serving pages. I’ll have to wait awhile before I get to the management page again so I can start restarting mail services but it doesn’t seem to help. I have to reboot the server.

Any suggestions on what to look for? I’m on a VM so should I just spin up a fresh install and use my automatic backups to hopefully restore everything.


(Filippo Carletti) #2

You could try to access the system through ssh and open /var/log/messages: you will probably find some errors. Post it here if you need help analyzing it.


(Bill ) #3

I didn’t see any errors in the messages log but I’ve done some additional investigating. It appears my problem is related to DNS. I’m running a rather unconventional setup on my network. I’m using my tplink router to provide IP addresses through DHCP with a lot of reservations so addresses don’t change for some devices. That way if NethServer is down I can still contact devices using their IP address. NethServer is used for DNS so that I can set local names and point them to the right addresses when I’m on my local network.

My main machine runs linux Mint and VMWare work station 14 with windows 7 on a VM. If I run thunderbird on both Mint and the VM it appears to freak out my network interface and I can only get to NethServer using it’s IP address, not DNS.


(Markus Neuberger) #4

Hi @happnatious1,

you may try “nslookup YourNethserver.domain.tld” on your VM to see which DNS server is used and if you get a result.

The VMWare network interface should be in bridged mode which means same network as your Mint and your Nethserver.


(Bill ) #5

Thank you Markus, using nslookup helped me find the problem and fix it.