Proxy issue on matomo

Has anyone ever encountered a similar error using matomo

i am trying to install modules, but i get that error.
it links to the site here:

If you’re using Nethserver reverse proxy to host matomo then you may try to change this advanced setting in the reverse proxy:


i am just using virtual hosts. so not sure where the deal is

I tested Matomo too and tried to monitor my website. It works well.

Where or at which module install do you have this issue?

i have been trying to install the kdap module. and mainly any other module i try, i get the error

I didn’t use a virtualhost, I put the matomo dir from the directly to /var/www/html/matomo and I installed the LDAP module now without problems.
I’m going to check it in a vhost…

oh, so your installation is mainly on domain/matomo

Also, i noticed there are other configurstion option, in terms of enabling maxmind and others.
shouldnt we just create matomo as a module. it looks like an average php cript, but not very…

Good idea. We could preconfigure LDAP/AD and other nice modules.
Unfortunately I have a lot of other open projects at the moment that I’d like to finish…

i understand

i know you are being pulled left right and center.
maybe if i could get the means on how to do it… i can deploy a test server, and use it to train on how to build moudles for nethserver.

1 Like

Yeah, that’s a good idea.
Check out other Nethserver web based module projects on github to get some ideas.
Matomo would be a good module to start with.
If you need help just ask…

do i need to build my own repo, to be able to create a moudle?

No, it’s not necessary. If you build your module you get an RPM file that you can install locally or put on your webserver and install on a client with yum install http://<YOURWEBSERVER>/<yourmodule>.rpm

well, seems av got some learning to do…
ok, on your side, when you can figure out the matomo issue on vhost, let me know

1 Like

Here it works in the vhost too.

Do you use a proxy for the web clients? If yes try to disable it for testing.

Did you set correct permissions?

chown apache:apache /var/lib/nethserver/vhost/<YOURMATOMOVHOST>

Here are my vhost settings (I cut the FQDN):

1 Like

i checked the require ssl

i corrected, and even installed hp 7.3 but i am still getting the same error.

My install notes after creating the vhost:

\cp -r matomo/* /var/lib/nethserver/vhost/05ffwf7cfa0s6c4/
chown -R apache:apache /var/lib/nethserver/vhost/05ffwf7cfa0s6c4

Then I created db and user in phpmyadmin and went through the setup process on the webpage…

there is not much different, only that i used mv * /var/lib/nethserver/vhost/4f9615b30a5d35a/

and since i was getting erros with phpmyadmin, i used the default username and pwd, and matomo created its own db

this error is being caused by this extension

if you are using this extension just stop

when you disable the said plugin, youll get the error

but if you remove it completely, there is no error youll get.

kindly use the default nextcloud passwords extension