Problems withe Only Office Documentserver, cant create Documents in Nextcloud

To analyze:

Is documentserver running?

Check https://yourNethServer:8082.
systemctl status nginx -l
supervisord restart all

Is the Nextcloud onlyoffice app installed and enabled and setup correctly?

Check Nextcloud admin settings for correct IP/FQDN. If you used the package get the instructions in the wiki else in the howto.

Yes, there is a downgrade workaround to try…


I tried it and the workaround works with the module, I don’t know the exact steps for the ones who installed via howto by now…

VPN yes, but no access via SSH or Web UI. The server is dead.

Thanks for clarifying…

I updated the wiki entry for a fresh installation. I put yum install instead of using the repo. I tested it on a VM and it worked.

For an already updated broken installation when using the nethserver-onlyoffice package I recommend the downgrade:

yum downgrade
signal-event nethserver-onlyoffice-update
yum remove onlyoffice-repo

For those who used the howto I recommend to downgrade and install the package as it corrects wrong configuration files:

yum downgrade
yum remove onlyoffice-repo
yum -y install
yum -y install nethserver-onlyoffice

Check the wiki entry for instructions when using self-signed cert and how to set correct hostname…

Fully agree. With the downgrade/direct install way we keep the working version and may care about the update without pressure.

Can you make onlyoffice work again with the provided solution? @fausp Thanks in advance!

Yes, it worked.

If onlyoffice-documentserver was installed from their repo, until further notice it’s better to disable or remove the repo as it will be triggered by updates and bork it again:

yum remove onlyoffice-repo
1 Like

Sorry, the downgrade did not work for me… I restored the NS7-vm and installed it new, thanks to you Markus :clap:


1 Like

Thanks, I added it to the solution post and changed the workaround link in the wiki.