Problems withe Only Office Documentserver, cant create Documents in Nextcloud

Hi Markus,

there are no errors in the logs. Both logs you describe are empty.

Regards

Uwe

Does saving the onlyoffice app settings work or do you see an error on screen?

I can see no error on screen.
I only see the picture I posted above.
Can you give me a step by step guide on how to uninstall the software cleanly and then reinstall it. Practically as if it had never been installed on the server before.

I meant in the Onlyoffice app settings in the Nextcloud admin settings, you have to login as Nextcloud admin to see it:

Are the settings correct and do you see an error if you save?

To uninstall onlyoffice and nginx with all dependencies:

yum autoremove onlyoffice-documentserver nginx msttcore-fonts-installer-2.6-1 onlyoffice-repo

Installation steps are in the howto. I’ll try to provide a working module over the weekend.

You may try to install the documentserver directly and not via repo to not have the same error again:

yum install https://github.com/ONLYOFFICE/DocumentServer/releases/download/ONLYOFFICE-DocumentServer-5.0.7/onlyoffice-documentserver.x86_64.rpm

instead of

yum -y install onlyoffice-documentserver

1 Like

Remove onlyoffice and nginx stoped with the warning RPMDB altered outside of yum.

When i save the setting this error message is coming upUnbenannt

What I found you can ignore the “RPMDB altered” warning:

https://www.centos.org/forums/viewtopic.php?t=636#p201029

I assume the packages are removed, you may run the “yum autoremove” again to check it.

If you took the screenshot after removing onlyoffice, the error is clear.

It is simply not possible to remove the package.

Unbenannt

Running transaction and nothing will go on.

Sorry, no need to. The file is templated. AFAIK all problems came from onlyoffice package.

OnlyOffice Document Server Update warnings:

warning: /etc/onlyoffice/documentserver/default.json saved as /etc/onlyoffice/documentserver/default.json.rpmsave
find: ‘/etc/onlyoffice/documentserver-example/supervisor/’: No such file or directory
warning: /etc/nginx/conf.d/onlyoffice-documentserver.conf.template saved as /etc/nginx/conf.d/onlyoffice-documentserver.conf.template.rpmsave
warning: /etc/nginx/conf.d/onlyoffice-documentserver-ssl.conf.template saved as /etc/nginx/conf.d/onlyoffice-documentserver-ssl.conf.template.rpmsave

Relevant OnlyOffice Document Server update changes:

new directory : /etc/onlyoffice/documentserver/nginx
	number of new files		 : 7
new directory : /etc/onlyoffice/documentserver/supervisor
	number of new files		 : 6

deleted file : /etc/nginx/conf.d/onlyoffice-documentserver-ssl.conf.template
deleted file : /etc/nginx/conf.d/onlyoffice-documentserver.conf.template

deleted file : /etc/nginx/includes/onlyoffice-documentserver-common.conf
deleted file : /etc/nginx/includes/onlyoffice-documentserver-docservice.conf
deleted file : /etc/nginx/includes/onlyoffice-documentserver-spellchecker.conf
deleted file : /etc/nginx/includes/onlyoffice-http.conf

deleted file : /etc/supervisord.d/onlyoffice-documentserver-converter.ini
deleted file : /etc/supervisord.d/onlyoffice-documentserver-docservice.ini
deleted file : /etc/supervisord.d/onlyoffice-documentserver-gc.ini
deleted file : /etc/supervisord.d/onlyoffice-documentserver-metrics.ini
deleted file : /etc/supervisord.d/onlyoffice-documentserver-spellchecker.ini
deleted file : /etc/supervisord.d/onlyoffice-documentserver.ini

changed symbolic_link : /etc/nginx/conf.d/onlyoffice-documentserver.conf
    lrwxrwxrwx root root /etc/nginx/conf.d/onlyoffice-documentserver.conf -> /etc/onlyoffice/documentserver/nginx/onlyoffice-documentserver.conf.template

changed file : /usr/bin/documentserver-configure.sh

Relevant available directories:

/etc/onlyoffice/documentserver/nginx/
/etc/onlyoffice/documentserver/nginx/includes/
/etc/onlyoffice/documentserver/supervisor/

Tried to restore functionality by symlinks and also by putting files in place but no dice. I think it’s better to wait for upstream to release a new minor version, or track their open issues.
If you want me to do some tests just tell me (only running it on test server so no hurry on my side).

1 Like

Please try to reboot(maybe a yum process hangs) and if this doesn’t work try rebuilding yum db:

Source:

EDIT:

I got similar issue after playing with install/remove, some post install script seems to be the problem, the following worked for me:

yum-complete-transaction --cleanup-only
yum --setopt=tsflags=noscripts remove onlyoffice-documentserver

After rebooting the server, it is no longer accessible. I am 500 KM away from home and in a week back home. Either I get him back to the start, or he flies out of the window.:airplane::airplane::airplane:

Regards Uwe

Oh no! :sob: No SSH, no web UI, no VPN, no other possibility like remote software or virtualization management or something else? My VPS once took an hour to reboot, maybe try later…I hope you can bring it up again!

I did an update of my nextcloud/onlyoffice-Server… the nextcloud looks like:

grafik

How can I analyze the situation and is there a workaround or fix ?

To analyze:

Is documentserver running?

Check https://yourNethServer:8082.
systemctl status nginx -l
supervisord restart all

Is the Nextcloud onlyoffice app installed and enabled and setup correctly?

Check Nextcloud admin settings for correct IP/FQDN. If you used the package get the instructions in the wiki else in the howto.

Yes, there is a downgrade workaround to try…

EDIT:

I tried it and the workaround works with the module, I don’t know the exact steps for the ones who installed via howto by now…

VPN yes, but no access via SSH or Web UI. The server is dead.

Thanks for clarifying…

I updated the wiki entry for a fresh installation. I put yum install https://github.com/ONLYOFFICE/DocumentServer/releases/download/ONLYOFFICE-DocumentServer-5.0.7/onlyoffice-documentserver.x86_64.rpm instead of using the repo. I tested it on a VM and it worked.

For an already updated broken installation when using the nethserver-onlyoffice package I recommend the downgrade:

yum downgrade https://github.com/ONLYOFFICE/DocumentServer/releases/download/ONLYOFFICE-DocumentServer-5.0.7/onlyoffice-documentserver.x86_64.rpm
signal-event nethserver-onlyoffice-update
yum remove onlyoffice-repo

For those who used the howto I recommend to downgrade and install the package as it corrects wrong configuration files:

yum downgrade https://github.com/ONLYOFFICE/DocumentServer/releases/download/ONLYOFFICE-DocumentServer-5.0.7/onlyoffice-documentserver.x86_64.rpm
yum remove onlyoffice-repo
yum -y install https://smart-ict.services/mirror/mrmarkuz/7/noarch/nethserver-mrmarkuz-0.0.1-1.ns7.noarch.rpm
yum -y install nethserver-onlyoffice

Check the wiki entry for instructions when using self-signed cert and how to set correct hostname…

Fully agree. With the downgrade/direct install way we keep the working version and may care about the update without pressure.

Can you make onlyoffice work again with the provided solution? @fausp Thanks in advance!

Yes, it worked.

Edit:
If onlyoffice-documentserver was installed from their repo, until further notice it’s better to disable or remove the repo as it will be triggered by updates and bork it again:

yum remove onlyoffice-repo
1 Like

Sorry, the downgrade did not work for me… I restored the NS7-vm and installed it new, thanks to you Markus :clap:

grafik

1 Like

Thanks, I added it to the solution post and changed the workaround link in the wiki.