Problems setting up FTP


(Fabian Pitre) #1

Hi everybody, i hope you can help me. I installed a virtual lab on virtualbox: one vitual nethserver with two NIC’s (one in bridge mode and the other one with internal network) and one virtual pc with windows 7; all works fine, except for the FTP. I tried a lot of configurations but i can’t connect to FTP from the “outside” (my real pc). This is what i have configure:

  • eth0: bridge NIC with DHCP 192.168.1.X - This is my “WAN”
  • eth1: intenal network static 10.10.10.1
  • FTP installed and configured with one user, all from the GUI, no CLI for the moment
  • Service FTP created with TCP/UDP on port 21
  • Host neto (name of my server) created on Firewall Object (IP 10.10.10.1)
  • Firewall rule: Action: ACCEPT, Destination: ROLE RED, Service: FTP
  • Por forwarding: Protocol: TCP-UDP, WAN IP: Any (selected by default), Origin Port: 21, Destination Port: 21, Allow only from: I leaved blank

I use Filezzila to connect from my WAN to my LAN via port 21, but it’s just can’t. I don’t know what’s wrong.

Thanks is advance for any help, and sorry for my english.


(Giacomo Sanchietti) #2

If I understand correctly, you want to access the FTP server running on NS from the WAN.
A service which runs inside the firewall itself (like the FTP server), it is considered a “Network service”, thus you don’t need to configure a firewall rules, but you must change the access property for the service.

Steps:

  • remove the firewall rule
  • go to the “Networks services” page
  • change the FTP access option to public

See: http://docs.nethserver.org/en/latest/base_system.html#network-services


(Fabian Pitre) #3

Giacomo, thanks for the reply.

When i go to Configuration > Network, i see two interfaces (eth0= wan and eth1=lan) and there’s no options for set ftp to public. When i go to Configuration > FTP there are only two tabs ( user and configuration) and none of both have a option for set ftp to public.

I deleted all the firewall rules, firewall objects and port forwarding rules for ftp.

I can’t acces to ftp server from WAN yet.

I don’t know what else can i do to get the fto server working.


(Eddie Atherton) #4

Update the vsftp entry on the Network Services page to use both Red and Green interfaces.

Cheers.


(Fabian Pitre) #5

Thanks for the reply bro.

It’s done. Newbie mistake. Solved allowing the ftp service for green and red network. Like you guys said.

Thanks a lot for the help


(Alessio Fattorini) #6

Ehi Fabian welcome aboard, happy to know you resolved your issue. Next time you can check the @eddie’s answer as solution marking the topic as solved :wink: now I did it for you. have a nice Sunday!